4

I have problems with Notepad++ starting with Windows startup. The Notepad++ window does not show up. Only the process is loaded. I can't open any file with Notepad++ from context menu until the Notepad++ process is killed manually.

The solution would be simple not to start that process on startup. The problem is, I can't find the process starter neither in Autostart nor via msconfig. And I can't find the option not to start on startup in Notepad++ preferences.

Q: Why is the Notepad++ process loaded on startup and how to prevent it?

1
  • Try clearing the cache of files it tries to open on startup. Alternatively if you know how to clear a tab from the app without opening it you could try this method and tell me how you did it.
    – user96279
    May 17, 2013 at 9:18

5 Answers 5

2

Some times, programs can start via a scheduled task. So, check there for anything you're not sure of.

Also, and I can't think of why any program would do this for Notepad++, but it could be possible that another program is opening NotePad ++ (eg, a malicious script loads it up for no good reason).

Lastly, it is possible that an update has occurred on the software itself. So, yes, you are right to check the MSCONFIG but also look through the NotePad ++ settings and ensure that it is not set to load with Windows.

If none of the above help, then it is possible that the default programs are set incorrectly. For example (and this is a silly example but it does demonstrate the theory), let's assume my PC was set to open a web page every time Windows loaded but for a strange reason I bug made all web pages to open with NotePad++ (which I was unaware of), this could then occur. Although it's not typical, this has happened to me once before at work.

4
  • It could be something with opening txt file or similar... I have also this problem at work Jan 8, 2013 at 8:52
  • 1
    There are some JavaScripts that are being launched by admins. And they are launched in the most stupid way on earth, by giving the script path and hoping the application connected with the extension will launch the script. The Notepad++ takes over those extensions and so it is launched instead. But now I'd have to re-register all scripts extensions... Jan 9, 2013 at 8:01
  • Glad you got it solved, although I can only assume that took some digging!
    – Dave
    Jan 9, 2013 at 8:28
  • Well, it isn't solved because there are more extensions to change, but at least I know WHY ON HELL ;P Jan 9, 2013 at 8:34
6

You can check all different autostart options with Sysinternals Autoruns

enter image description here

This utility, which has the most comprehensive knowledge of auto-starting locations of any startup monitor, shows you what programs are configured to run during system bootup or login, and shows you the entries in the order Windows processes them. These programs include ones in your startup folder, Run, RunOnce, and other Registry keys.

1
  • 2
    +1 The best utility of its kind, and only got better since Russinovich joined MS and got access to the source.
    – Karan
    Jan 8, 2013 at 17:52
1

There are a number of places in the registry where autostart can hide.

Check e.g.

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce
  • HKEY_USERS\<< USERNAME >>\Software\Microsoft\Windows\CurrentVersion\Run
  • HKEY_USERS\<< USERNAME >>\Software\Microsoft\Windows\CurrentVersion\RunOnce

with regedit for any Notepad++ references.

1
  • nothing there... AFAIK msconfig shows all these Jan 8, 2013 at 8:50
0

@me the same malfunction occured, my solution: There are desktop.ini's in the startup folders on each account:

desktop.iniX [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Renaming brought the remedy.

1
  • I don't believe this is an answer for the actual problem. Renaming desktop.ini files will not change configured Run entries or the mandated scripts OP found to be the culprit in their case, or any other method I'm currently aware of that runs programs automatically. Feb 9, 2017 at 18:57
0

Lets not forget the good ol' Startup folder!

Type "shell:startup" at the Windows Run Prompt. You can do this by holding the Windows key and pressing R.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.