I am on a Windows PC running VirtualBox with Ubuntu installed. I have my networking setup as NAT. On my Windows PC, I am connected to a VPN, but I cannot access those VPN resources from VirtualBox (I have also tried Bridged Networking mode with the same result). Is there a way to connect through the host's VPN? Or alternatively if I could just connect to the VPN through Ubuntu that would work, but I don't see that option in the network connections when running within VirtualBox.


By default, the NAB adapter simply works for me, without Cisco AnyConnect running.

But DNS lookup failed when Cisco AnyConnect is running, this is due to a critical bug in Ubuntu 12.10+, "bug 1048783: network name lookups broken in NAT network adaptors". See more details at, https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1048783

To workaround this, you would need to run the following cmd to use the host DNS lookup,

From an window command prompt (with VMNAME replaced with your VB name, e.g. "Ubuntu"),

cd "c:\Program Files\Oracle\VirtualBox"

VBoxManage modifyvm VMNAME --natdnshostresolver1 on

BTW, I have "NAT" by default for the 1st adapter, and a "Host-Only" for the 2nd adapter to get around the limitations with NAB only adapter. This setting works perfectly for me.

Make sure you reboot the virtualbox and save the state to preserve the previous settings, not only a power off.

  • I have been looking for this answer for months! THANK YOU!!! – Kirkland Sep 25 '15 at 20:21
  • Still an issue in 2017. Thanks for the explanation and solution – Eldamir Mar 1 '17 at 11:26

I have had a similar problem. Running Windows 7 (64bit) with Ubuntu 12.04 inside VirtualBox. To work from home, I need to be able to connect to the University network via VPN to be able (in turn) to connect to the University supercomputing cluster.

I couldn't get a VPN client connection from inside Ubuntu, and I was unable to access my Host machine's VPN connect.

What I did was create a new adapter for my Virtual machine, attached to "Host-only Adapter". This showed up under Internet Connections in Windows, and from there I created a bridge between my Cisco VPN adapter and the VirtualBox host-only network.

After doing this, I was able to connect to the VPN host from inside the Ubuntu virtual machine. The Windows side of the VPN connection doesn't like it, but meh.

Hope this helps.

  • Thanks. It turns out I just forgot to set the adapter as connected. – Jeff Storey Feb 18 '13 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.