A user at work has a problem with Office 2010 and IE 9 against Sharepoint 2010.

Whenever the user clicks on a Word file (.docx) on Sharepoint, he first gets the normal dialog asking whether to open it in read only mode or check it out.

sharepoint checkout dialog

After confirming that he wants it checked out, the dialog closes, but then the normal IE download "dialog" yellow pane shows in the bottom of the window asking whether to open or save the document.

internet explorer open save dialog

If he clicks on Open, the document is opened from the temp folder, but not linked to Sharepoint, so saving and/or closing it will never upload the changes, nor ask if he wants to check it in so others can use it.

Additionally, when the file opens in Word (from the temp folder), it is flagged as unsafe, and is read only, with a yellow bar at the top with a button for allowing editing. This is a quick indication that everything is not as it should be.

I had a similar problem, but this was solved by using the 32-bit IE instead of the 64-bits version, but he's already using the 32-bit version so that's not it.

What else should we look at?

Answers to comments/questions:

  • The user has Windows 7 Professional installed
  • The user is part of a company domain (and is not logged in just locally)
  • The user has administrator rights on the computer (he is a developer after all)
  • The problem occurs on the Sharepoint site itself, not just when following links from somewhere else
  • The expected behavior, if you're unfamiliar with the Sharepoint integration, is that Word should open the file after the initial dialog (that asks about read-only/check out), the yellow "dialog" at the bottom of IE should not appear, and the bar at the top of the Word file about an unsafe document should not appear. If he opts to check out the document, it should immediately open in Word, ready for editing.
  • What version of Windows? Also, is the user part of a domain? – Dane Jan 11 '13 at 18:13
  • Answered your questions in the question itself. – Lasse V. Karlsen Jan 11 '13 at 20:55
  • So, what's the actual expected behavior? No yellow bar and it instantly opens the file in Word? – Der Hochstapler Jan 11 '13 at 22:59
  • @OliverSalzburg: Correct, after the initial dialog asking whether to open it read only or to check it out, it should immediately open in Word. The yellow "dialog" should not follow. – Lasse V. Karlsen Jan 13 '13 at 14:42
  • Since it's only one client, the problem might be caused by some add-on. You could test if this happens in IE safe mode : "iexplore -extoff". – harrymc Jan 13 '13 at 15:13

This Microsoft KB2661910 seems to match your situation 100%. It also come with a Fix It in the article.

  • I hope this works for @Lasse, but do note this caveat in the article: NOTE: This only happens when opening the Office document BY CLICKING ON A HYPERLINK (as in an email message) and the Office document is located in a SharePoint 2010 document library. If the user browses to the SharePoint 2010 document library and opens the file from there, this issue does not occur. – Dane Jan 11 '13 at 19:54
  • @Dane I understand that. Lasse only mention IE9 in the question, so I just give it a shot. If this does not work, it will be a looooooong check list, Or maybe your answer will work :D – John Siu Jan 11 '13 at 19:59
  • The problem occurs when the user is on the Sharepoint site itself, but we'll be certain to give the fix in that article a try come monday. I'll post the results, if any, when we have tried it. – Lasse V. Karlsen Jan 11 '13 at 20:50
  • Hey, I definitely hope this fix does it for him. On second reading, that quoted section may refer to web interface vs file explorer. @Lasse, does opening the document library in Explorer (not Internet) allow him to effectively open and save files? – Dane Jan 11 '13 at 21:15
  • @Dane: I am unsure, I'll ask him to check this on Monday. – Lasse V. Karlsen Jan 13 '13 at 14:43

This can be caused by a user disabling the Office Document Cache Handler add-on in Internet Explorer, often due to overexcited culling of add-ons thanks to the "Speed up browsing by disabling add-ons" prompt.

To resolve it and re-enable the add-on:

  1. In IE, access the Manage add-ons dialog via the Tools button:

    Manage add-ons menu item in the Tools menu

  2. Ensure that the Office Document Cache Handler is enabled:

    The offending add-on, and Enable button

This add-on is what handles SharePoint-Office document caching and integration within IE.

  • There are no disabled extensions or plugins in his Internet Explorer configuration. – Lasse V. Karlsen Jan 18 '13 at 22:13
  • @LasseV.Karlsen Does that addon exist in the browser? – John Siu Jan 18 '13 at 23:23

Okay, I really don't have a prescient answer for you, but I have a couple places for you to look. If you provide more detail, I might be able to narrow down my response.

First of all, if the user has a Home edition of Windows, or is on Vista, I'll point to that as being a likely source of problems and throw my hands up in the air (and you'll need someone else to answer).

Here's one thing to try: In Internet Explorer, go to Internet Options, then the Advanced tab. Near the end of the list of Settings, there is one labeled, "Enable Integrated Windows Authentication." Set it to the opposite of what it currently is, restart your computer (you can probably just close IE, but better safe than sorry), and see how things work.

As you might be able to tell from my ideas here and my clarification request, I'm betting that this has something to do with the way the user is authenticating with the SharePoint server.

  • He has Windows 7 Professional (or higher, this is a company, so he's certainly not on Vista or some home edition). We'll twiddle that setting and see what happens come monday, and I'll post the results, if any. – Lasse V. Karlsen Jan 11 '13 at 20:51
  • Unfortunately it didn't change anything. – Lasse V. Karlsen Jan 18 '13 at 15:00

There may be some resolution in rolling back IE9 to IE8. There seems to be many similar issues with sharepoint and IE9.

Go to Control Panel >Programs>under Programs and Features> view installed updates and scroll down to the bottom of the list and uninstall Windows IE9 and then restart. IE8 should now be present.

  • If it comes to that, it may be a solution. It's quite odd though, if that is the solution, since the whole department should be using the same software (not "should be" as in "has to", but we're using systems coming from a template, and all windows updates should have been installed), and I don't know of anyone else that has this problem. In other words, I'm using the same IE he does, and it works for me. – Lasse V. Karlsen Jan 13 '13 at 14:44
  • Maybe roll back see if it works then update back to IE 9 and see if it works. – Carl B Jan 14 '13 at 18:04
  • Unfortunately we're unable to do that at this point. – Lasse V. Karlsen Jan 18 '13 at 15:01

Fix idea: Put the Sharepoint site in the user's trusted sites list and ensure that trusted sites are set to the Low security level.

Trouble-shooting ideas:

  1. If you have another machine with the same software versions installed and it works, compare the "Custom level..." settings from the Security tab between the two computers. Also compare the Advanced tab settings.
  2. Have the affected user log in to a known good computer with his own user account. Does the problem follow the user account?
  3. Have a known-good user (yourself?) log into the affected user's computer. Does the problem affect all users on that computer?
  • The site is already listed as a trusted site. – Lasse V. Karlsen Jan 18 '13 at 22:13
  • Have you fixed the issue? If not, have you tried these trouble-shooting ideas? What were the results? – Dane Jan 28 '13 at 18:59

I had a user with the exact same issue. The machine is Windows 7 Pro x64, with IE10, Excel 2010 and SharePoint 2010. She'd click a doc on SharePoint, it would prompt to check it out; but once opened in Excel it would still be read-only and no options to check it out.

This is going to sound crazy, but the issue was being caused by her display resolution being set to medium. I changed it to the default 'smaller', and now she can check in/out docs and it works.

Hope this helps someone out there.


The banner issue solution is below: https://support.microsoft.com/en-us/kb/2661910

The banner shown either before or in yellow is determined by screen res.

  • Try to add the most important content of the link in your post, it will prevent your answer from suffering from link rot when the link goes stale. – MoonSire May 12 '15 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.