0

I am currently trying to start up using Virtual Hosts using xampp with Apache. I can not figure out what is wrong with my code in the http-vhosts.config I have followed many tutorials and read a bunch of troubleshooting forums but cannot understand why my apache will not start if i try to implement a virtual host. Right now I am just trying to get local host to work.

NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
<VirtualHost *:80>
    ServerAdmin postmaster@dummy-host.localhost
     DocumentRoot "e:/xampp/htdocs"
    ServerName localhost
    ServerAlias localhost
     ErrorLog "logs/localhost-error.log"
    CustomLog "logs/localhost-access.log" common
</VirtualHost>

<Directory "E:/xampp/htdocs">
    Options Includes FollowSymLinks
    AllowOverride All
    Order Deny,Allow
    Allow from all
</Directory>


# localhost name resolution is handled within DNS itself.
127.0.0.1       localhost
::1             localhost
127.0.0.1 foo.local
0

Try this, Add Directory tag into VirtualHost tag

<VirtualHost *:80>

   <Directory "E:/xampp/htdocs">
   </Directory>

</VirtualHost>
  • Ok that works but when I add Options Includes FollowSymLinks AllowOverride All Order Deny,Allow Allow from all it stops working – imtrying Jan 9 '13 at 6:41
  • figured it out had to change Deny,Allow to lower case deny,allow , if any one can enlighten me on this extremely annoying reason it would give me a piece of mind thank you. – imtrying Jan 9 '13 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy