I want to analyse what raw-data rsync transfers across for a sample input file. So I am using rsync over rsh (As traffic captured in wireshark will be easy to interpret).

I am using following rsync command :- but there is no traffic generated when I apply filter of rsh in wireshark

akshay@akshay:~$ rsync -avz checkport.txt --rsh ajay@
sending incremental file list
-rw-rw-r--             25 2013/01/09 22:19:14 checkport.txt

sent 67 bytes  received 76 bytes  286.00 bytes/sec
total size is 25  speedup is 0.17

also ,I get following error when I use rsync the following way over rsh

akshay@akshay:~$ rsync -avz -e rsh checkport.txt ajay@
Permission denied.
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(224) [sender=3.1.0dev]

But, in this case the traffic is generated in wireshark for rsh.(but,its data is not visible). Permission denied is reply from the remote side

Additional info: - rsh-server and rsh-client is installed on both hosts. please bring to my notice , if I am missing anything here.

[EDIT]: Also , I have put rsync as filter option in wireshark still no traffic is captured when I run rsync command. What Do I do to capture rsync traffic in wireshark. Thanks in advance.

  • Posting on multiple sites does not help. Having all answers in one place helps future users. – Dave M Jan 10 '13 at 14:49
  • @DaveM : I was not quite sure about this question belongs to serverfault or superuser. – Akshay Patil Jan 10 '13 at 16:35

the --rsh/-e option expects a command to be specified and your first command is missing that - to be equivalent to the -e rsh in your second command you need --rsh=rsh. It is probably therefore just using the default (ssh) for that attempt (check for ssh traffic when you run the test to confirm/refute this).

As it looks like rsync's first response is to report that the connection has been closed I suspect the permission denied error is coming from rsh/rshd rather than rsync reporting it is having trouble opening the specified files/directory. I suggest trying an interactive login (rsh ajay@ to see if you get logged in OK, I suspect you will get the same error. If so, then make sure that the rsh daemon is actually running and listening for connections, make sure that you are not blocking the rsh port (514 IIRC) by some means, and review the rsh configuration file on the server: you may find it has limits by default that are blocking your user's login.

  • yes,rsync -avz -e rsh checkport.txt ajay@ this command works for me after adding ajay and to /etc/hosts.equiv and also traffic is captured for RSYNC as well as RSH protocol fileter in wireshark. – Akshay Patil Jan 10 '13 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.