12

After installing updates which require a reboot, the Windows 8 Power button shows "Update and Restart". What I really want is "Update and Shutdown". How can I get this option to appear? I didn't realize it even existed until I saw it on my system where only "Update and Shutdown" had been available. I gathered this happened because I did not install pending updates for a day or so. Shift/Ctrl/Alt clicking on the choices bring no new options.

There is a group policy which has been around since XP SP2 which will prevent this from showing up, but I have not found a way to force it to show whenever updates are pending. The thread No more update at shutdown? in Microsoft Community discusses this issue as well.

Digging further I found the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\Power\OfferInstallAtShutdown-Final which looks related but could not find any documentation for it. It is set to 0x28 on my system. When I changed it to 0x01 it came back after reboot as 0x28. When I changed it to 0xff it stuck after reboot but neither option changed my Power button options.

Reading Minimizing restarts after automatic updating in Windows Update I see that Install at shutdown is a popular option. Is it not offered when the updates require more work after restarting?

This superuser thread is related: How can I install updates and shut down from the command line?

[edit 9/12/2013] Using shutdown.exe /s /t 0 from the command line as suggested by @Vargas below installed the update and shut down as desired when Power>Shutdown did not. The real question remains which is how can this be done consistently through the GUI?

3
  • 1
    The default shutdown is the is new hibernation boot and Windows needs to do a reboot to get the old Shutdown where it can install the updates. Commented Jan 11, 2013 at 4:58
  • @magicandre, thanks for that. I read up on it in Delivering fast boot times in Windows 8 and the article mentions the new /full switch on shutdown.exe. I will see if this helps next time.
    – User5910
    Commented Jan 16, 2013 at 4:26
  • the full flag was removed in the CP/RP. Now the shutdown.exe does a normal/full shutdown by default. If you want the new start, you must use the /hybrid flag. Commented Jan 16, 2013 at 11:23

4 Answers 4

2

It appears that Microsoft has added an "Update and Shutdown" option into Windows 8.1. Hopefully it is here to stay in future versions of the operating system.

1
  • 1
    I hoped this was the case but I ran into the same issue again this week. There is some improvement though--after opening Windows Update and installing pending updates, the Power>Shutdown option turned into Power>Update and Shutdown.
    – User5910
    Commented Jun 12, 2015 at 3:43
6

From This question on SO, you can update and shutdown with (just tested and worked fine):

shutdown -t 0 -s -f 

It does not show the option on the menu, but does the job!

4
  • 1
    True, this lets the update install where using Shutdown on the Power menu does not for the updates I installed today. I've updated the question to mention this, thanks.
    – User5910
    Commented Sep 12, 2013 at 23:45
  • From the documentation: /f Force running applications to close without forewarning users. The /f parameter is implied when a value greater than 0 is specified for the /t parameter. So this does not make sense to do -t 0 and -f Commented Sep 2, 2014 at 18:59
  • 2
    @DarkWalker, that's not my reading of the doc: since /t 0 is specified (i.e. /t value is not > 0), you do need to specify /f if you want it Commented Nov 19, 2014 at 18:03
  • @BobSammers You are correct! Commented Nov 19, 2014 at 21:10
2

You need to disable hybrid boot in order to get the 'update and shutdown' to become visible. This is because hybrid boot speeds up the time to shut down your computer, and giving you the option to install updates with a shutdown will make the computer turn off slowly.

This shows how to disable hybrid boot in order to enable the 'update and shutdown': http://www.maketecheasier.com/disable-hybrid-boot-and-shutdown-in-windows-8/

6
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Commented Mar 20, 2015 at 6:16
  • The question asks how to get update and shutdown instead of update and restart, not how to disable hybrid boot and shutdown.
    – fixer1234
    Commented Mar 20, 2015 at 6:26
  • This fix is what enables "update and shutdown". update and shutdown is disabled because of hybrid boot
    – Quintonn
    Commented Mar 20, 2015 at 9:35
  • @Quintonn - Without the relevant information in the question itself this answer isn't that helpful.
    – Ramhound
    Commented Mar 20, 2015 at 11:03
  • So because there might be info missing in the question you down vote my answer?
    – Quintonn
    Commented Mar 20, 2015 at 14:34
1

This probably cause in your scenario is the new Hybrid Shutdown mode offered by Windows 8. I’ve seen this happen on a system where hibernation had been previously disabled, causing some confusion when the system was upgraded with the new shutdown procedure which uses a new form of hibernation which has then failed to work.

Solution :

Open up a command prompt as Administrator and type

powercfg /H on

Hope It works for you.

1
  • Thanks for the suggestion. I already have hibernate enabled though.
    – User5910
    Commented Jan 16, 2013 at 3:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .