Windows 8 is set to sleep after 30 mins, and it used to work, but recently it's started refusing to sleep. (I can still manually ask it to go to sleep without any issue.)

Put the computer to sleep: 30 minutes

I was having issues a while ago, but it was with my network adapter. That's since been disabled, so it's definitely not that:

enter image description here

I've checked to see what devices are able to wake up my machine, but it only appears to be my mouse:

Powercfg -devicequery wake_armed

Which is odd, because I haven't recently changed my mouse, and more confusing still: The monitor does go to sleep just fine. If it was actually the mouse keeping my system awake, I'm pretty sure the monitor wouldn't go to sleep.

I've checked my Wake Timers, and nothing:

enter image description here

I've also checked my existing requests...

UPDATE: I found something. What to do with it, I don't know...

enter image description here

Note: Even when /requests says that there's "NONE" under every category, my machine still won't sleep(!).

enter image description here

In short: How can I tell what's preventing my computer from Sleeping?

UPDATE: Ok, so I now have a few more pieces of the puzzle. I came back to my computer and it was ASLEEP! Lawks! It seems that the only times it doesn't sleep is if VLC Player is open, even if a video isn't actually playing.

UPDATE UPDATE: Ok, so it won't sleep sometimes when VLC Player ISN'T running, either. Bah!

  • If it might be the mouse, try it with the mouse unplugged to confirm?
    – Journeyman Geek
    Commented Jan 21, 2013 at 15:27
  • Hmm. As stated in the question, the mouse hasn't changed, and it would stop the monitor from sleeping if it was that... Right? Isn't there some Event which details why it can't sleep? :-/ If you still think it's worth a try, I'll do it. Commented Jan 21, 2013 at 15:43
  • Check Administrative Tools -> Task Scheduler for any tasks that are set to go off. Eg, AdobeFlash, GoogleUpdate, RealPlayer, etc will have tasks that may be scheduled as often as every 5 minutes. Commented Jan 22, 2013 at 3:02
  • Kind of a nitpick, but have you tried letting it go into hibernation? Personally, I can't remember sleep ever functioning correctly outside of new installs. I have always had issues with services running in the background keeping it awake. Usually it's a virus scanner. Not saying this is your situation. I just keep mine on hibernation. (Not the same thing, I know) Commented Jan 30, 2013 at 9:38
  • 1
    I am currently also having this problem. Nevertheless, I would not like my computer to go to sleep while playing videos. Moreover, I found out a curious thing. When I disable automatic turning off of the screen, the computer goes to sleep automatically. But it won’t go to sleep automatically after an automatic turning off of the display. That seems very strange. Anyone having this same behaviour?
    – josefec
    Commented Dec 26, 2013 at 14:31

16 Answers 16


There are several things to check:

  • Power configuration of course
  • Task scheduler
  • automatic wake up for maintenance (network wake up)

I assume your computer is up to date. As you have found that no requests exist, it could not be an interrupt which is causing this. However, its better to check BIOS settings and device manager settings to know which settings and which devices are configured to interrupt. Plus a compatible BIOS update is necessary to let interrupts function accurately.

Besides that, there are problems with multimedia players such as VLC. If it was running, the computer will refuse to sleep. A small piece of software can be found here (which may or may not assist you since you have Windows 8. It works with Windows 7 though).

  • That software looks like it's made just for me! I'll try it out. Thanks! Commented Jan 24, 2013 at 12:32
  • 1
    It is VLC keeping my computer awake, and it's through the SrvNet process it does it. If I override that process, then my computer goes to sleep WHILE THE VIDEO IS PLAYING :( It looks like the piece of software is just what I needed. Thanks! Commented Feb 3, 2013 at 20:42

To answer my own question, it seems that to discover what's preventing your system from sleeping, you can run powercfg -energy and let it do a trace. The resulting report revealed the following for me:

enter image description here

Which lead me to:

enter image description here

  • 1
    This was helpful. System Availability Requests:System Required Request The program has made a request to prevent the system from automatically entering sleep. Requesting Process \Device\HarddiskVolume5\Program Files\Synergy\synergyc.exe Synergy is a program that lets one computer's keyboard/mouse control another computer. So that makes sense!
    – Ryan
    Commented Apr 13, 2014 at 20:36

My current testing suggests that this problem is (or can be) caused by running processes.

When running powercfg /requests two processes were listed under the SYSTEM category:

  • Print Spooler
    was trying to still print a document

  • Windows Media Player Network Sharing Service
    was waiting for playback instructions

After shutting down both services, the system hibernated as expected.

Regarding \FileSystem\srvnet, I found the thread Not sleeping due to : \FileSystem\srvnet which suggests that this is also related to media sharing.

Finally went to: Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

And under media streaming - blocked all - and that did the trick! I don't know if there's another way to allow streaming and enable sleeping, but for now, beats running all night long after waking for a time update etc... :-)

  • @JohnnyW: Sorry it didn't work out for you :( Sadly I now no longer have a system that displays this issue :\ Commented Jan 22, 2013 at 2:03
  • Huh! You may have been right, after all. I just found something in my /requests. Any clue? Commented Jan 22, 2013 at 12:27
  • @JohnnyW: Check this out: Not sleeping due to : \FileSystem\srvnet Commented Jan 22, 2013 at 14:07
  • Thanks, I saw that, but unfortunately it hasn't helped -- bah! (If you see the comments, a lot of Windows 8 folks are saying the same.) Commented Jan 23, 2013 at 14:01
  • 1
    @JohnnyW: So, when you run powercfg -energy now, it lists nothing? Commented Jan 23, 2013 at 14:40

Here's another option: set the sleep time to a short time (e.g. 1 minute). Then wait a minute. Your computer shouldn't be gone to sleep, as per your description. Then, you might be able to see in powercfg -lastwake what the problem was, if your computer tried to sleep, but was woken up immediately.


In a Command Prompt (cmd) run as Administrator enter this command :

powercfg /requestsoverride driver srvnet System

You can use WinSleep to diagnose many sleep issues like this - it shows you a history of sleep/wake times. Some other features they include are:

  • Keeps your computer asleep (while not too busy) as much as possible during periods you specify.
  • Provides a detailed time-line graph showing when your computer was awake, asleep, or hibernating.
  • Provides convenient Sleep and Hibernate buttons for manual use when desired. Shows the current CPU/Disk/Network usage percentages for your computer.

  • 2
    Can you explain HOW you would go about diagnosing problems using this software? Commented Jun 20, 2016 at 14:56
  • This really worked, thank you. I tried everything, but my windows server 2019 wouldn't go to back to sleep after it was woken by the LAN - I tried everything. Winsleep fixed it & gave me a lot more control & options on controlling sleep over what the operating system does. Highly recommended.
    – ShrapNull
    Commented Apr 27, 2022 at 8:16

It is an issue with HOMEGROUP in Win8.1 Pro. Mind you, the HOMEGROUP computers that are preventing sleep don't even have to be turned on! Basically, I had to take the three computers in the house and have them leave the old HOMEGROUP. I then created a new HOMEGROUP with a new password and made sure that I could share files and folders back and forth. One computer was a bear and I had to stop sharing entire folders and files (shift-left click to select all files and folders, right click-sharing-stop sharing) and then share the one folder that I wanted to.

To verify that this is your problem, just disable the network adapter and set the sleep to one minute. Wait 5 minutes and see if it sleeps.

Now the two Win8.1 Pro computers sleep! (takes a couple of minutes to fall asleep so some patience is needed).


I created new power scheme set it for 5 min to sleep ( so I could check) "Change Advanced Settings".... On the to "paragraph" of the window is "Change Settings that are currently unavailable" Then scroll down to "Sleep"-Expand "+" "Allow Wake Timers" - "Disable"

Wait to test and it Works

Now set the sleep time for the period you want

Mine is 2 hrs.


See here, I figured it out finally for my issues: Win 8.1 not going to sleep

I used an option (/WAKETIMERS) which I had not seen too often before on any helping forum, thus I'm posting it here:

powercfg /WAKETIMERS

-> To see the scheduled tasks. Helped me figure out to disable the Windows regular maintenance, which avoided sleeping completely (and not only waking it up in the night).


In my particular case, leaving the homegroup immediately fixed this problem. Note that setting 'When sharing media -> Allow the computer to sleep' didn't fix it at all.

My powercfg /requests was identical to the one shown in the original question.


My quess is that the answer is in Task Scheduler. Thanks to your screen shot, we can see your regular maintenance is set. Perhaps it fails at 02:59 and is set to retry?

Have a look in the Task Scheduler Library, if necessary, drill down to the Microsoft and then Windows folder.

  • Yes, it is set to retry when the computer is idle for "0 minutes" (oddly enough). Surely there must be some way for Windows to let me know what's keeping it from going to sleep, though? :-/ Commented Jan 12, 2013 at 10:20
  • My logic is powercfg / waketimes tells you what's waking. Task Scheduler allows you to adjust (disable) the task, hence 'Get the job done' that is bringing it out of sleep prematurely.
    – Guy Thomas
    Commented Jan 12, 2013 at 10:37
  • Thanks, Guy. The thing is that it's set to run the second the machine goes idle... So it should have definitely run long before the 30 mins timer tries to put it to sleep. Commented Jan 12, 2013 at 11:20
  • Hi, just thought I'd let you know that I'm still having the same problem and my WakeTimers are now completely empty :( Commented Jan 21, 2013 at 15:25

Here are the steps to follow when you want to check which process is preventing your system from sleeping:

  • Open Command Prompt (Admin) [in Windows 8, right-click in the bottom-left corner]
  • Type powercfg /energy
  • Wait 60 seconds for it to finish
  • Open the folder c:\windows\system32
  • Sort the files in it on Date Modified
  • Copy the file energy-report.html to the desktop, then open it (with your web browser)
  • Read this document to find out which errors were reported as preventing the system from sleep
  • Try to fix those errors (search the web for "error xxx preventing sleep windows")

E.g. if the “print spooler” is reported to be preventing sleep, go to Devices & Printers control panel, open your printer device, and remove all unfinished print jobs from the queue (i.e. cancel all documents).


I had a similar problem when I upgraded from Win7 to Win10, my computer would no longer go to sleep. The solution for me was to go into Settings-->System-->Power & Sleep-->additional power settings-->change plan settings-->change advanced power settings. Find "sleep" and set "Allow hybrid sleep" to DISABLED. This fixed my problem.


look at this page helpdeskgeek.com/windows-8/fix-windows-8-1-will-sleep/ It prints a report. The errors are the important part. I couldn't open the html page so i right clicked on the html and opened in word.(you can try write or anything else) There were about 11 errors. The audio driver was one that kept it from sleeping along with srvnet. For the audio driver the report will list the requesting driver device. Mine was VIA High Definition Audio. You have to open cmd in administrative mode and type in the following: *powercfg -requestsoverride "VIA High Definition Audio" system . In quotes type in the name of your requesting driver. My other problem was srvnet. Open cntrl panel, network and sharing center, change advance sharing settings, then turn off all media streaming options.

  • 1
    I see the link didn't show up so open cmd prompt in administrative mode and type in powercfg.exe /energy. A report will show up in C:\Windows\System32 and open the energy-report.html
    – Bob Lee
    Commented Jun 6, 2016 at 3:18

I solved this using the powercfg -lastwake showed the device as the ethernet adaptor

Set this to not allow wake and now computer auto sleeps. (oddly it would sleep when told to before)


I too had issues with computer not going to sleep in automatic mode, but it would go to sleep in if I did it manually. Found out it was due to my Asus Asuite 2 set at high performance mode. Switched it to auto mode and it solved the problem

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .