91

When I play a video in VLC it always starts with subtitles! I don't want this! I want subtitles OFF until I choose to turn them ON.

I tried unchecking 'enable sub-pictures' in the preferences menu, but this removed the subtitle user interface entirely, making it difficult to get subtitles on the occasions I really do want them (foreign films).

3
  • 2
    This seems to be the default now in VLC 3. 0 and above. Finally they got it right.... Jun 27 '18 at 4:51
  • Not what is being asked, but (in Ubuntu): v to cycle subtitle track, and shift-v to toggle subtitles.
    – Daniel
    Jul 28 '19 at 19:29
  • The solution is simple, just cover up the bottom of your screen, either with some kind of object or with another window. :D
    – Andrew
    Dec 9 '20 at 7:15
64

I know this is kind of an old thread, but if someone else is looking for the answer, I found an easier way.

In the simple settings menu, go to "Subtitles/OSD" and under "Preferred Subtitle Language," enter none. Subtitles will no longer be displayed unless you ask for them! This works in VLC 2.2.1 and 2.2.4 (windows 7 and 10 respectively) for sure, and probably others too, but I have not tested it beyond those two.

Hey VLC guys, how about just making the default none, so we don't have to do this? Pretty please??

4
  • This is BY FAR easier than all the other suggestions above and works like a charm, I'm on version 2.2.4 weatherwax with macOS. Please, upvote this answer for more attention.
    – chiappa
    Apr 5 '18 at 1:09
  • Preferred language option is no longer there in the latest version 3.0.4
    – charsi
    Jan 10 '19 at 5:36
  • 2
    Option has been moved to Input/Codecs > 'subtitle language'
    – charsi
    Jan 10 '19 at 5:40
  • Works on macOS too with latest VLC 3.0.8 Mar 25 '20 at 21:58
82
  1. Browse to the menu Tools / Preferences / (Show settings: All) / Input/Codecs
  2. Then set 'Subtitles Track ID' to 0

enter image description here

per http://forum.videolan.org/viewtopic.php?f=14&t=62294

10
  • 35
    +1 Warning to others, there's also an option just above Subtitles Track ID called just Subtitles Track that won't work. What a complicated way do disable something that should be disabled by default. I mean really, how often does the average person actually want their native language subtitled?
    – devios1
    Jun 16 '13 at 1:47
  • 4
    wow so obvious how did I miss that ಠ_ಠ
    – Damon
    Dec 11 '13 at 3:10
  • 16
    Completely unintuitive.
    – Koobz
    Jan 8 '14 at 7:18
  • 3
    They totally need to make this more prominent and simpler. Also it should default to off - most people don't want subtitles on.
    – niico
    May 25 '15 at 20:47
  • 1
    Also, you need to click the "Show All" settings button to find these preferences. Jun 28 '16 at 12:31
20

Setting it to 0 doesn't always work. It works about 50% of the time. I set mine to 99 which seems to work better ;-)

4
  • 4
    The accepted answer didn't work for me, but this did. Thank you.
    – nc01
    Sep 21 '13 at 8:22
  • 1
    Same here - accepted answer didn't work; this one did.
    – David
    Feb 24 '15 at 3:42
  • -1 is used to disable subtitles (or any other track)
    – user25
    Feb 25 '18 at 17:43
  • This is what worked for me. Setting to "none" or setting track ID to 0 didn't. Thank you! Sep 1 '18 at 7:35
3

Just wanted to say that you can do this using the "simple" options as well: it's tools / preferences / and then "subtitles/OSD" which is the 4th big button on the left of the preferences menu, right above "input/codecs."

Then just uncheck "enable subtitles," the subtitles will remain available anytime via r-click/subtitles.

Also, after doing this, then switching to "show settings: all" in the lower left, the "subtitles track ID" that Colonel Panic suggests, is set to -1, not 0, which could be why some folks are having trouble with it. You can manually set this to -1, to achieve the same result. Cheerio!

1
  • 1
    The question clearly says they don't want to disable subtitles, they want them off by default. Also -1 does NOT disable subtitles it makes the subtitles go to the default language. Sep 1 '18 at 7:27
1

This answer corresponds to VLC 3.0.4 Vetinari on an ubuntu system. The subtitles can be disabled by unchecking Enable Subtitles on Tools-->Preferences-->Subtitles/OSD screen.

It can be enabled by pressing v during the running of video.

Screenshot below

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.