This question has been asked throughout the web, but I am simply not able to get it working.

I am Running Windows 8 Pro (x64), when I connect to the office network, I can connect to all network shares except the ones that is on our (NAS).

As soon as I boot into Windows 7, I am able to connect.

So far I have tried the following:

  1. http://support.microsoft.com/kb/2686098
  2. http://help.unc.edu/help/connecting-to-nas-with-windows-8/
  3. http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/c1d2e480-65e8-41ad-b7a4-73d4ba3ca09d
  4. Windows 8 Pro NAS not recognized? (tried all suggestions)

All of the above with no success.

I also tried the net use command, to see if it might return additional info, but i get Error 53

net use k: \\omsmds001\
System error 53 has occurred.
The network path was not found.


net use k: \\
System error 53 has occurred.
The network path was not found.

When i ping the device i get no response

When i try and browse the network location, i get an error:

Windows Cannot access \\omsmds001
Error Code: 0x80070035
The network path was not found

I have disabled "SecureNegotiate" and i can't enable SMB on the device, it is out of my control.

UPDATE I have had some luck here: I connected to a server that is on the domain, i pinged the server again and received a different IP address. I used that IP address and i am now able to map the disk with the IP. using host name still fails in windows 8.

  • 1
    Please see my post here on SU superuser.com/questions/531992/windows-8-pro-nas-not-recognized/…
    – Dave
    Commented Jan 15, 2013 at 10:57
  • i tried all those options as well, thanx.
    – stoic
    Commented Jan 15, 2013 at 11:04
  • 1
    What is the make of the NAS, and did it come with any software?
    – Dave
    Commented Jan 15, 2013 at 12:52
  • i have no idea, i work for a large corporate (no access to anything). I used a workaround a few months ago that worked, but had to format my pc this weekend, and now i cant find the workaround anymore.
    – stoic
    Commented Jan 15, 2013 at 12:56
  • 1
    error 53 is a name resolution problem, have you tried net use with the IP Address? net use \\ technet.microsoft.com/en-us/library/cc940100.aspx
    – MDMoore313
    Commented Jan 17, 2013 at 18:40

6 Answers 6

  1. IP address

    Check Windows 7 and Windows 8 are using same subnet and gateway. Use following command


    If Windows 7 can ping the device, Windows 8 should be able to also.

  2. Turn off firewall

    In file explorer, go to following and turn off firewall

    Control Panel\All Control Panel Items\Windows Firewall

    If you have other firewall software like norton360, you will have to disable it within those software.

  3. Check file sharing is enable

    In file explorer, go to following

    Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings

    Under section All Networks, check File sharing connections, select Enable file sharing for devices that use 40- or 56-bit encryption

  4. Check remembered credentials

    In file explorer, go to

    Control Panel\All Control Panel Items\Credential Manager

    Click Windows Credentials. Check if there are credential related to that NAS, delete it.

  5. WiFi and Wired

    If you have both w-fi and cable connection, try turn off wi-fi.


As I understand it, you need to map a share on a NAS, you cannot map the NAS itself. So try

net use k: \\omsmds001\nameOfTheSharedFolder

Whether or not your share works with the name (as opposed to the IP address) could depend on various factors, such as

  • your DNS setup - does the configured DNS server know about the NAS's name?
  • the WINS setup - is there a WINS server in your network
  • the Windows Domain setup - are you part of a domain, does the domain controller know the NAS name, does the NAS know your domain controller and is part of the domain

SO my NAS by dlink couldn't be seen wither and Synology help was of no help either. I tried uninstalling my LAN driver, re-installing it, trying every thing on this forum:


Also enabled SNMP under components/enable windows features

What I think finally helped was this:

Go to System in Win 8. This is really easy on the metro screen type system then in settings its right there. (this screen has your Windows Experience rating)

Under Computer name, domain, and work group settings to the right it says change settings. Clink this.

Under Network ID it will have 2 bubble options: This computer is part of a business netowork or part of a home computer. I chose HOME COMPUTER option. Restarted and problem solved. Good luck!


Same problem for me, Win7 machines could see the NAS drive and shares, Win8 64 Pro could not.

If you can connect to the NAS via IP (e.g. \\\ ) try adding an entry to the hosts file - it worked for me.


Add a line with the fixed IP address and device name, e.g. NAS

now use file explorer to navigate to \\\NAS.

  • nice idea for editing the hosts file, makes things alot easier if someone sends you a link to the NAS via email
    – stoic
    Commented Aug 29, 2013 at 9:07

The fix is easy:

  • Find your way to the registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecuritySignature

  • Set the parameter to 0

Microsoft acknowledges this issue and has two workarounds: "System error 2148073478," "extended error," or "Invalid Signature" error on SMB connections in Windows 8 or Windows Server 2012


I had the same problem after recently installing windows 8, and after trying several more or less complicated solutions, what fixed it was the same as davefromcamp's solution (I'm not allowed to upvote yet, but I wanted to share that this worked for me as well, and that it was a really simple solution)!

What made the trick was:

  1. Open up "System" from the Control Panel. One way to access the control panel is to hover the mouse in the right upper or lower corner, slide the cursor to Settings, click, and then select Control Panel from the list. Click "System and Security" and then "System".
  2. Under "Computer name, domain, and workgroup settings" click the "Change settings" link, located at the right next to an administrator shield icon.
  3. On the first tab "Computer name", click the button that says "Network ID..." This opens up a window with only two choices.
  4. Select "This is a home computer; it's not part of a business network". Click finish and let windows restart itself.

Hope this can help more people with the same problem!

  • I can't quite grasp the topic of the question, but have you considered editing the answer you're referring to? :>
    – kluka
    Commented Jun 15, 2013 at 11:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .