I've been running into a problem where some of the applications from the startup menu don't actually start upon login. After looking at the list of the applications I've noticed that actually only the exe files that I've set in properties to "Run as administrator" (in compatibility tab) don't run (and also a .cmd file).

How do I run those apps during startup?

  • It could be absurd asking but can I know at what location have you kept all those files? – pragmatic Jan 16 '13 at 7:03
  • %AppData%\Roaming\Microsoft\Windows\Start Menu – Wojtek Jan 17 '13 at 7:44

Use the good old Task scheduler approach to start applications with elevated rights at startup.

  1. start Task Scheduler and create a new task
  2. mark the checkbox "Run with highest priviligies"
  3. under action point to the exe you want to run
  4. give the task a name and save it
  5. create a new shortcut

    C:\Windows\System32\schtasks.exe /RUN /TN "MYTASKNAME"

  6. copy this shortcut into the startup folder

There is also a tool called UAC Pass which does all the steps for you.

  • ok, thanks - that's answer it thus it's accepted. tho... I went a bid different direction and disabled UAC alltogether.. yup, I don't have metro now which made win8 basically a win7 ;-) – Wojtek Jan 17 '13 at 7:45
  • ok, but it is not best practice to disable the UAC. – magicandre1981 Jan 17 '13 at 19:43
  • well... why? :P it's my OS, I don't install any new software on it and tip-toing over annoying features was anoying... – Wojtek Jan 18 '13 at 20:28
  • 1
    because 90% of the security flaws in Windows come from using admin rights. – magicandre1981 Jan 19 '13 at 6:16
  • riiight... I've been using computer since mid '90s, always with admin rights/UAC disabled and uhm.. never had problems? (only FW, no AV). But on the other hand - I'm also turning of for example JS on 90% of internet ;) – Wojtek Jan 20 '13 at 9:07

I think that using the task scheduler to autostart programs is not very user friendly, and sometimes it has had side effects for me (e.g. tray icon for a program is not added).

To remedy this, I have made a program called Elevated Startup that first relaunches itself with administrator privileges, then it launches all files in a directory. Since Elevated Startup is now elevated, all the programs it then launches is also given administrator privileges. The directory is on the start menu next to the classic Startup directory, and works very much the same.

You may encounter one UAC prompt when the program relaunches itself, depending on your UAC settings.

You can get the program here: https://stefansundin.github.io/elevatedstartup/


Windows will not run any program that has "run as administrator" or "run as compatible" set. You need to run an "ordinary" program that then runs your application.

I use a program that uses the Windows "shellexecute" function with the "runas" verb, such elevate.exe ( https://www.winability.com/info/elevate/ ),or write your own such as (Deplhi6):

program runasadmin;


uses {SysUtils,} shellapi{, windows};

var s : ansistring;

begin s := paramstr(1); ShellExecute( 0, 'runas', @s[1], nil, nil, 1 ); end.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.