I have a Windows Home Server 2011 box with an Athlon 64 X2 dual processor, 6Gb RAm, and 4 2Tb disks configured as a couple of mirrored raid arrays. I use this box to run nightly backups of the 4 desktops and 2 laptops on our home network, and to store all of our family's important data, such as documents, music, pictures, home videos (our kids make a lot of videos!) etc.

The system has been running fine for over a year, but recently it has developed serious issues:

  • Booting the machine can take over an hour
  • Sometimes it takes 30mins plus to respond to CTRL-ALT-DEL before displaying the login screen.
  • Logging into the console often takes 30 minutes plus (I can no longer use RDP to access the machine). The login primarily hangs at the "Please wait for the user profile service" message, but every once in a while I can get in quickly.
  • Shutdown takes forever, especially when applying updates. (The most recent shutdown took 14 hours!).
  • Once logged in on the console, the system is very unresponsive. Initially the start menu is often OK, but starting some applications, especially anything that requires mmc, such as the event viewer or services manager is ridiculously slow (over an hour to respond to a mouse click.) The task manager shows nothing using CPU and memory use at around 18%.

I have run chkdsk and I have run memtest86+, both were clean. I have tried with network cable unplugged with no difference.

I really want to look at the event log, but mmc just will not cooperate.

My most recent searches suggest I should try a clean boot, but I have not been able to run msconfig yet.

Incidentally, once the machine is running and I am lucky enough to get through login and access the remote storage from another machine the access is fast and reliable (unless I am trying to use the console at the same time).

I am a software engineer by trade, but I have built 30+ desktop machines over the last 15 years. This is the first time I have seen anything like this.

I have searched for similar situations, but most seem to relate to Windows Server 2008 in a domain role with remote profiles, which is not relevant here. I have tried one suggestion relating to resetting windows update, but it does not seem to have helped. I am in the middle of re-enabling the windows update service right now and the properties box has not responded yet from when I clicked the apply button over 2 hours ago. (mmc has been at 50%+ usage for that entire time, with significant kernel activity of 40-60% of that..)

I would appreciate any suggestions for how I can track down my issue or if there is a more appropriate forum for this question a link to that site.

migrated from serverfault.com Jan 16 '13 at 18:30

This question came from our site for system and network administrators.

  • 1
    Remove drives, perform a clean install of windows on a new, or spare drive. Is everything good? If not, then hardware, if yes, the something about the software is screwed up. Consider a backup, re-install, format. – Zoredache Jan 16 '13 at 17:50
  • Thanks for the suggestion, the hardware is fine. I booted an old install disk and windows ran fine. I really don't want to reinstall as I'm not sure how to preserve all my backups across a server reinstall. I'm still hoping someone will have a suggestion on what could be wrong and how to clean the system up. – mjs0 Jan 16 '13 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.