I have a host machine running virtual box on Windows 7. I have 12 physical cores, and have tried to share them with my virtual machine (windows XP Pro SP3).

When I look and compare the task manager on my virtual machine it only shows one CPU core. And when it's running at 100% the CPU on the host is only running at about 7%.

It looks like the guest OS is only using one CPU core even though I've said use more. Any idea why this is?

(I've tried to tell it to use 2, or 4 as well, so it shouldn't be because it can't handle 12.)

enter image description here

  • Did you originally install XP when you only had 1 cpu available? – Mokubai Jan 16 '13 at 20:43
  • The host had multiple CPUs, but I believe when the image was created, it was only allocated 1. – Frantumn Jan 16 '13 at 20:46
  • 1
    In that case check Lorenzos updated answer, looks like he had the same thought as me and has given a possible fix. – Mokubai Jan 16 '13 at 20:53

If you are using windows XP home edition this issue is caused by windows itself, as it only supports 1 core.



this may also be caused by a HAL error, originated from installing windows xp with single core capabilities, and then it refusing to change to multi core. the solution to this is as follows:

get devcon util from microsoft, then get these commands on:

devcon sethwid @ROOT\ACPI_HAL\0000 := +acpiapic_mp !acpiapic_up

devcon update c:\windows\inf\hal.inf acpiapic_mp

note: backup any sensitive data!


  • Thanks for the tip. I'm running Pro with SP3 though. Any other thoughts? – Frantumn Jan 16 '13 at 20:35
  • does the virtual machine have its extra tool pack installed? – Lorenzo Von Matterhorn Jan 16 '13 at 20:36
  • If you mean Guest Additions, yes. And both Virtual box, and the guest additions are up to date. – Frantumn Jan 16 '13 at 20:37
  • then the processor settings must be wrong somehow in virtualbox, can you doublecheck please? namely VT-x – Lorenzo Von Matterhorn Jan 16 '13 at 20:38
  • 3
    If you you installed XP onto a single core host then a single CPU HAL gets installed. Later increasing the number of CPUs does not replace that. Q: did you originally install it on a single core? – Hennes Jan 16 '13 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.