My mouse will reconnect/disconnect (will even hear the sounds from Windows), and the light on the bottom of the mouse will turn off/turn on as it starts working again.

It really sucks to be playing a game (and happens on desktop as well) for the mouse to just die out for a few seconds and come back. Sometimes it will not happen for days and other times it will do it two or more times within 15 seconds.

I tried two different wired mice, tried multiple USB ports (on the front of the computer, back of the computer, used a USB hub and plugged in a card that connects to the USB connectors on the motherboard and adds a few USB ports to the back of the computer, and I also bought a USB 2.0 PCI card and that did not help).

Nothing else seems to reconnect like this, my USB keyboard has never once cut out like the mouse does and neither have any of the other devices I have connected (webcam, USB hub, various devices sometimes connected through USB cables, and IR receiver for windows Media Center remote). I have disconnected all USB devices except for my keyboard and mouse and the problem still occurs.

I guess it could be something wrong with my motherboard but since no other devices behave similarly I'm just hoping that it is some kind of driver conflict. Installing Logitech's drivers has had no effect. It seemed at first that if I go to Device Manager and uninstall HID-compliant mouse (that and Logitech mx518 are listed) that would fix it, but it doesn't seem to work anymore or at least not every time (it keeps re-installing).

I have googled "USB mouse disconnects and reconnects", and it seems to be fairly common but none of those were resolved.

To stick some easy steps:

  • It happens with or without the drivers installed
  • It has happened with multiple mice on the same computer
  • The BIOS is the latest version (P08)
  • Motherboard drivers are the latest version
  • Device Manager isn't listing any problems on any USB devices
  • Happens with every USB port, even addon USB cards
  • Happens when all USB devices aside from mouse and keyboard are unplugged

I read that maybe it is an IRQ conflict, and I tried to look into that but did not really know what was going on, but didn't see anything obviously wrong.


  • 5
    I'm having the exact same problem. I notice that the disconnect happens much more frequently while playing a game.
    – deft_code
    Dec 26, 2010 at 23:28
  • 1
    I'm having the exact same problem as well. I also agree with what @deft_code said, it mostly happens when playing games. Recently it has started happening with my keyboard (simple Logitech one) However, it mostly affects my mouse (Logitech mx518) and another mouse (also a Logitech gaming mouse). May 18, 2012 at 16:28

9 Answers 9


If you're experiencing mouse lockups or failures, it may be because your computer is automatically turning off the power to a USB Root Hub.

  1. Go to your Control Panel > System > Hardware tab > and click on the "Device Manager" button.

  2. In the Device Manager window, find the item or items labeled "Universal Serial Bus controllers." Open it, and double-click the first item called "USB Root Hub."

  3. In the USB Root Hub Properties dialog, click on the "Power Management" tab.

  4. "Allow the computer to turn off this device to save power" is checked by default. Uncheck this box, and click "OK."

If this does not work, do the same for the USB Input Device - uncheck the box "allow the computer to turn off this device to save power. (this worked for me) and stopped the annoying way the mouse would go in and out.

  • 1
    @Aaaayu: I have 8 "USB Root Hub"s. I disabled the power off feature of the first one listed and it did not effect the problem.
    – deft_code
    Dec 26, 2010 at 23:34
  • 4
    I just got a 10-port hub that was doing exactly this (I would hear the Windows device disconnect/connect sound every few seconds). I just unchecked "Allow the computer to turn off this device to save power" and all is quiet. Thanks so much!
    – metadaddy
    Apr 16, 2012 at 16:28
  • 4
    In addition to this, I also had to disable the mentioned checkbox, but under Human Interface Devices > USB Input Device(s) Mar 10, 2015 at 12:59
  • 1
    So if you have several of those mentioned entries, how do you know which is the one causing the problem?
    – Dane411
    Jan 26, 2017 at 1:39
  • @Dane411 If the USB hub is attached externally to your system - e.g., a monitor extension, just disconnect and re-connect it and watch what changes in the Device Manager. If you need to identify the on-board device you need to restart and disable it from the BIOS. Jan 6, 2021 at 10:44

Supposedly this can be caused by registry corruption:

This issue can occur when the device enumerator located at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet gets corrupted. As a result, the mouse attached to the USB controller is duplicated and the system gets confused. Periodical attemtps to remove the dupe are discarded after re-detecting the mouse attached to the controller.

That page recommends a system restore or uninstalling the USB device in Device Manager.

In addition to uninstalling the device itself, you can uninstall all the USB root hubs on your machine, and they will be reinstalled after a reboot, as recommended in this HP article USB devices are detected by Windows but are not working properly:

5.Double-click Universal Serial Bus Controllers to expand the list.
6.Right-click the first USB Root Hub in the list and then select Uninstall . Continue uninstalling all USB Root Hubs.

uninstall root hubs

You can also uninstall all previous instances of the device (and the root hubs) using a tool like USBDeview. It will show you all devices that have ever been installed, even if they aren't currently plugged in, and you can uninstall them from there, so the "detected new hardware" thing will pop up the next time you plug it in. Sort them by vendor ID, select everything related to that product, right click, and uninstall them all.

USBDeview showing unplugged devices

I'm not sure if the registry corruption is truly the cause, and I'm not sure if this actually fixes it, but it's worth a try. It seems to be working for my most recent experience with this problem.

  • 1
    I tried all other answers in this question, but none of them worked. This was the last thing I tried, and it has seemed to solve the issue. Although I did have to manually shut off my computer with the power button due to all my USB devices being uninstalled. Be prepared for that anyone who tries this solution. Oct 19, 2015 at 5:46
  • @JesseNewman19 So what happened afterwards? :P
    – Dane411
    Jan 26, 2017 at 1:48
  • @Dane411 After I had to shut down the PC? It all went ok. Everything auto-reinstalled itself when I started it back up. The original problem came back later though. I ended up getting a new USB cable to actually solve the problem, heh. Jan 26, 2017 at 20:06
  • @JesseNewman19 I eventually developed a problem where all the USB ports would be yellow warnings after booting, and I wrote a script to disable and enable them all on boot to keep them working, and then eventually got a new computer :D
    – endolith
    Jan 26, 2017 at 20:07

From what you describe, nothing immediately comes to mind what the cause of the issue you are observing might be.

A few things to keep in mind:

  • The longer it takes to reproduce the failure, the longer it'll take to debug unless you are lucky. Your best bet is to try to find a way to reproduce the failure as quickly as possible.
  • You can count on experience and a consistent method of debugging (i.e. the "shotgun" debugging approach rarely produces the expected results -- not that I'm saying that is what you are using).

Typically, I would start with a minimum system setup to rule out the variables (1 CPU, 1 CPU Fan, 1 DIMM, 1 Video Card, 1 Hard Drive, 1 Power Supply, etc.). It is best if you have all "known good" components. Then, try to rule out subsystems. Unfortunately, at home you likely have limited tools and resources, so you have to improvise smartly.

Rule out the OS/drivers (easy if you have spare CD's & hard drives):

  • Does this happen when you run the system from a Linux boot CD?
  • Does this happen with any other OS installed?
  • Does this happen with a clean install of your current OS?

Rule out the keyboard and mouse:

  • Do your keyboard and mouse/mice always work on a another system?

Rule out the motherboard power rails:

  • Does the 5V rail at the USB slots stay near 5V or does it dip (a meter may tell you this, but an oscilloscope can give you a better idea if the power rail dips)?
  • What does the 5V rail look like on the PCI USB card?

This answer might now solve your problem, but hopefully it'll move you towards finding the cause of the issue.

  • 3
    Yeah, if you haven't yet, it would be good idea to swap the mouse with another computer and make sure it's not the mouse itself.
    – Nathaniel
    Oct 10, 2009 at 22:25
  • I have no idea how I'd go about ruling out the motherboard power rails since i don't have an oscilloscope or any multimeters or anything like that. I don't have any other OS's installed however this DID happen when I was running vista 64 bit (the problem followed after I formatted and switched to windows 7 64-bit. I haven't tried my mouse on a different system however I did try a different mouse on this system and that one messed up as well.
    – Marc
    Oct 13, 2009 at 23:16
  • If the issue still shows up after a clean install of Windows 7 from Vista, then that points to the hardware (either motherboard, power supply, or mouse/keyboard). Since another mouse also fails, then I would inspect the motherboard, specifically around the USB connector and South Bridge chip to see if there is any discoloration, missing componoents, or anything that looks different from the rest of the board. The USB traces usually snake through the PCIe/PCI slots from the SB to the connectors.
    – hanleyp
    Oct 14, 2009 at 1:32

You can try to uninstall the mouse completely and let Windows re-install it.

Go to Control Panel and into MouseHardware Tab → PropertiesHardware Tab > Uninstall

This will make your mouse stop working, so use your keyboard to restart your computer. When it loads, your mouse should be working fine.

  • There is no "Hardware" tab in Properties. There is a Driver tab, with Uninstall, but the button is greyed out.
    – endolith
    Jul 18, 2013 at 15:41
  • In Windows 10 it's Control Panel -> Hardware and Sound -> Devices and Printers -> Device Manager. (You can also just search for "Device Manager"). I dug into "Mice and other pointing devices", found the mouse, and selected "Uninstall device" from the right-click menu. That fixed the problem for me. Sep 12, 2018 at 14:01

I had the exact same problem with two 1600 MX-518 mice.

After the first one did that that I called Logitech support and they asked me the problem, asked for the serial number and then shipped me a new one free of charge. This happened again with my second one, but I did same thing and they shipped me a new 1800 DPI MX518. This is the mouse I am using now for over two years and it's been great.

I know I applied a lot of pressure to the cord of my mouse, and that could be the reason for it.

Here is Logitech's support website, and if your mouse is still under warranty, I highly recommend Logitech support.


If it happens with several mice and several USB interfaces, that leaves software. Are you using the Windows default HID driver for mice? You might try installing the latest software from Microsoft: http://www.microsoft.com/hardware/windows7/support.mspx

This is a regular USB mouse, not a wireless one, right?

How does it behave after a clean boot? http://support.microsoft.com/kb/929135

  • I tried it with a clean boot - had no non-windows services running and it still did it. I looked at the microsoft support page but my mouse isn't listed there since it is a logitech mx518 and not a microsoft product.
    – Marc
    Oct 13, 2009 at 23:14

Had similar problem for a year on Windows 10 with my Logitech G102.

Reinstalling driver would not help. And changing ports would help for 10-60 minutes. But here what I noticed, I have two HID-complaint mouse entries in Device Manager:

enter image description here

If I remove one of them in a short time it will reinstall itself. So instead I disabled it (Right Click → Disable device).

Note that for me it worked only when I disabled top one.

Its been two weeks and no disconnects yet!

  • Mine was similar. I had an old mouse I no longer use still in there. I removed it.
    – PRMan
    Jan 29 at 21:57
  1. Look at the Windows event logs to see if there is any indication of a service/driver failure.

  2. Look at the motherboard settings for integrated peripherals.
    Check the setting for USB on chip support. The manual is not clear on the meaning, however, I did have a system that when legacy (1.1 & 2) was enabled, USB devices would disconnect.

    From the manual I cant tell for sure what the setting on this motherboard means. If you disable on chip the keyboard and mouse are forced to enabled (according to manual) this would seem to imply the enabled setting allows access to other USB devices outside of windows (like boot from USB).


In my case, the problem became less severe when I started using a different USB slot.