Unicode / font configuration headaches. I've installed tmux-powerline and, per the recommendation, patched my Inconsolata font. The goal here is to display cute little wedge-arrow things, like U+E0B0, in the status bar.

For the life of me, I cannot make URxvt display them. Just shows a box.

The patched font is stored in ~/.local/share/fonts. I am positive that my font cache is up to date. fc-cache -fv reports that it successfully caches the folder and fc-list includes a line for Inconsolata for Powerline.

URxvt is using the correct font. URxvt*font: xft:Inconsolata for Powerline is the only URxvt*font setting in my .Xdefaults. I don't see any other settings in the URxvt man page that look relevant, though there's a lot there I don't understand.

The patched font definitely includes glyphs for these codepoints. sfddiff on the original and patched fonts reports that they are included in the patched but are missing from the original.

Per the Arch Wiki, Urxvt ignores any fonts.conf solutions or the like. What else can I check to locate the problem? And what's the best font / unicode tutorial you've found on Google, because I'm totally stuck.

1 Answer 1


rxvt-unicode doesn't support glyphs in the Unicode Private Use Area unless it's compiled with --enable-unicode3. This is also explained in the docs.

  • 1
    Nothing like getting feedback from the project owner! Unfortunately I forgot to update the question to note that I do have unicode3 enabled in my build (found that part of the docs later). I'm still poking and prodding at this one; if I figure it out I'll post the answer here, and if appropriate will drop you a comment on GitHub. Feb 12, 2013 at 20:14
  • 2
    The original link is 404. New direct link to the urxvt item: powerline.readthedocs.org/en/master/… Feb 23, 2016 at 23:52
  • Try with Hack instead of Inconsolata?
    – DK Bose
    Sep 17, 2019 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .