1

While connected to a VPN, I have to use a proxy to connect to the internet. Normally the proxy config file is located in an online location, and the web browser LAN settings is pointed to that. I wanted to make a few modifications to make things more efficient, and so I downloaded the .pac. However, when I point Internet Explorer to the identical local copy, the proxy no longer works. The local copy works perfectly with Chrome. What could be causing this?

2 Answers 2

1

Perhaps the VPN login is enforcing a Group Policy setting? When logged in on the VPN, can you check the proxy settings?

Perhaps you could post the pac file somewhere so we could check it.

Also, don't forget that the pac file is actually a JavaScript subset so you can use alert() to raise alert messages to see what is actually happening as the file is processed.

3
  • Wups, I forgot I had asked this. I actually figured out the answer through an unrelated question.
    – SaintWacko
    Jan 19, 2013 at 17:52
  • No worries. Please mark your own answer as the answer. Jan 20, 2013 at 11:43
  • Had to wait a little while to do so.
    – SaintWacko
    Jan 20, 2013 at 23:20
1

I discovered the problem was that I needed to add the file:// protocol before the path to the pac file, and to replace the backslashes in the path with forward slashes. I use Chrome myself, and it is intelligent enough not to need that, so I was unaware that Internet Explorer required it.

1
  • Also, any script errors in the *.pac file will make IE revert to its original settings.
    – TFM
    Jan 19, 2013 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.