I have a 32 GB USB stick. I was in Mac (VMWare) putting some stuff on. Then accidentally removed the drive. I put it back in, and wanted to format it. Using disk utility, I chose 1 partition, it automatically filled in 312 GB and I just clicked format or whatever. It didn't take long, then I could see the progress bar hanging at "Waiting for device to reconnect". Nothing happened for a while so I ejected it. Now comes the problem:

In Disk Utility (Mac): No sign of the USB drive.

In Paragon Partition Manager (Windows): No sign of the USB drive.

In Disk Manager (Windows): I can see that it's there. But it says: Disk 1 Removable (D:) No Media. When I right click it, I can only assign drive letters to it. No way to format.

In diskpart (Windows): diskpart list will show me the following: Disk 1, Status: No Media, Total Size: 0 B. When I eject the drive, the disk 1 will disappear. So I know that it's this drive. If I type clean, it will say that "There is no media in the device".

In HDD Low Level Format Tool 4.25 (Windows): Doesn't detect it at all.

In Device Manager (Windows): It is detected as USB Mass Storage Device.

In Gparted (Linux): Doesn't detect it.

In HP USB Disk Storage Format Tool 2.1.8 (Windows): It detects device as: "GENERIC USB Mass Storage 1.00 (0 MB) (D:)". When I press Start it gives me this error: "There is no media in the specified device"

In BIOS: Detected

In Spinrite (Live Boot): Doesn't detect it

Any help is appreciated.

  • 3
    plug it on linux, then on gparted erase the partition table and format it to ntfs(or other fs you desire) Jan 18, 2013 at 21:49
  • It doesnt detect it. Will update first post Jan 18, 2013 at 22:01
  • There is a later version of the HP tool: softpedia.com/get/System/Hard-Disk-Utils/… though I honestly don't think it will help. Jan 18, 2013 at 22:45
  • Same error as first post Jan 18, 2013 at 22:47
  • 4
    Grasp the stick between thumb and forefinger. Rotate arm laterally such that hand is positioned over round container next to your desk. Release. Feb 25, 2014 at 18:06

5 Answers 5


I've had lots of success with HP's usb tools when I have bricked my USB drive.

Try this link.

Hm, if this didn't work, I may have given you the wrong link as the tool I used to recover multiple dead flash drives with the same problems was a few years old, I'll try to find the right one.

  • Tried it, updated first post Jan 18, 2013 at 22:42
  • 3
    And I WOULD NOT recommend using the CNET spamware downloader! Jan 18, 2013 at 22:44

You seem to have exhausted the free tools and the only thing I can suggest if the drive is important is to try Spinrite though it is quite expensive, it often works where others utilities fail. It regularly recovers drives that seem beyond hope. It will work on USB disks as long as you BIOS supports them.

Honestly though, I think that it's a write-off. I have one that is dead too.

  • Does Spinrite work on flash drives?
    – Bigbio2002
    Jan 18, 2013 at 22:55
  • As stated, if your BIOS recognises them - so if you have a BIOS capable of booting from a USB stick, then, yes it does. Jan 18, 2013 at 22:56
  • Well, they have a money back guarantee. If it doesnt work, i believe that it didn't serve it's purpose. Will try it now. Jan 18, 2013 at 22:58
  • Steve Gibson and co are certainly reputable and very fair. I brought a license some while ago simply to support them though I've since used the tool to recover a laptop hard drive and doubtless I'll use it on other PC's over the years, in fact my fathers PC is in need of some help just now. Jan 18, 2013 at 23:06
  • I really had hopes for Spinrite. But it didn't detect the USB. I will try on another computer. But I won't believe it's going to work. Jan 18, 2013 at 23:51

Please try using Partition Wizard

If the drive is showing on it, delete the existing partition and create a new one. Hope it will work.

  • This isn't a drive partition in the usual sense, it appears as two separate devices. Some USB or external hard drives do this now.
    – LawrenceC
    Feb 27, 2014 at 1:54

I'm quite convinced you completely borked your USB drive. After all, a USB pen-drive is little more than an SD card. Given how terrible QA testing they have on those devices, it would be interesting to know what exact brand and model you used? Finally, there must be a good reason why you need to enter the size when formatting...

If there is something of extreme value on that stick, you could try to interface directly with FTL by trying to find a serial line on the chip or nearby. Perhaps you could flash a new FW to it?


If the drive is visible under *nix like systems in /dev folder, I would try to zero it by dd or pv. Then try to make it usable (create partition). Sometimes it help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.