Is it possible to lock the S/PDIF output sample rate to 44.1 on a Creative External Sound Blaster Live! SB0490?

I have recently attached my SB0490 to a new Windows 7 computer with the latest drivers from Creative. Previously I had it connected to a Windows XP computer and there was a program in the Creative group of the Start-menu that allowed me to configure the sample rate of the output.

In Windows 7, the only place I can find to make such a setting is the “Shared Mode” “Default Format” under the Advanced Tab of the SPDIF-Out settings. I'm not sure if this is the same thing or not.

enter image description here

I changed the setting to 44.1 but when I opened a recording program (GoldWave) the output changed back to 48k. I had to change the same setting in the “Line-in/Mic-in” settings to get the output to revert back to 44.1k.

enter image description here

It's a problem for me because whenever the sample rate changes, it causes all my downstream devices to hick-up while they re-synchronize and that sounds very loud and bad.

I also found the “Supported Formats” settings, but they do not seem to have an effect on the S/PDIF output sample rate.

enter image description here


The Sound Blaster works natively in 48000 Hz

The EMU10K chip introduces a lot of distortions when it downsample ( dunno if upsample is possible above 48khz) This is done automatically depending on the source. if you're listening to a 44.1khz sample then the soundblaster will be forced to downsample from 48 to 44.1 which is not done correctly as i said above.

So the best way is to not change anything. just let your soundcard work in 48000 Hz.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.