Using Totem Video Player v2.26.1 on Ubuntu Jaunty 9.04, dvd's won't play after I've installed libdvdread4, added the Medibuntu packages, and run

sudo /usr/share/doc/libdvdread4/install-css.sh

If I click on the dvd I get an error *"Could not read from resource". If I navigate to one of the videos directly and run it, the movie will play, but with obvious degradation or encryption (like cable tv you aren't paying for).

2 Answers 2


WorkAround: Switch to VLC.

  • 1
    technically that's a "workaround" ... VLC does its own decss, so if that's why Totem isn't working, no other program that relies on the system decss will work either. Oct 11, 2009 at 14:21
  • Good point. I'd still like to get another answer (that's why I haven't accepted it).
    – C. Ross
    Oct 11, 2009 at 15:54

I had the same problem. I run Ubuntu 9.10 but I doubt this issue has much to do with the version of ubuntu. If you have all the dvdcss stuff installed AND VLC doesnt work (has css built into it) then it is not likely css.

I looked into the /var/log/syslog file and found an error about the region not matching.

So I ran regionset (see this link for more information: https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs) and set the region from FF to FE. FF i think is "not set" and FE is region 1.

sudo apt-get install regionset
sudo regionset
regionset version 0.1 -- reads/sets region code on DVD drives
Current Region Code settings:
RPC Phase: II
type: NONE
vendor resets available: 4
user controlled changes resets available: 5
drive plays discs from region(s):, mask=0xFF

Would you like to change the region setting of your drive? [y/n]:y
Enter the new region number for your drive [1..8]:1
New mask: 0xFFFFFFFE, correct? [y/n]:y
Region code set successfully!

Then dvd playback worked perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .