8

I work out of London office and my office in all its wisdom has the proxy in Germany which means whenever I type something in Chrome's omnibox, it does the search via http://www.google.de instead of www.google.co.uk.

Question

How can I change it to use google.com/ncr

What I have tried

I have tried to update settings in Chrome as follows but even then it does not work.

enter image description here

  • Note: Advising to change the default search to Bing is a strict No-No! – Kanini Jan 21 '13 at 11:01
9

It's not working because you haven't edited [google:baseURL].

Use this string

https://www.google.com/search?q=%s

EDIT: See comments

  • Thanks! But I am not able to edit [google:baseURL] field in Chrome. It is Read Only. – Kanini Jan 21 '13 at 11:58
  • You can create another Search Engine String and make it default. – DragoonHP Jan 21 '13 at 12:01
  • 1
    Brilliant! Worked like a charm! – Kanini Jan 21 '13 at 12:06
  • This doesn't work for me, but I'm not completely clear on the exact steps required. – Simon Woodside Sep 24 '15 at 18:07
  • @sbwoodside: Go to chrome://settings > Click on Manage Search Engines and the add the relevant details in the empty textboxes in the bottom. – DragoonHP Sep 26 '15 at 14:52
4

Edit Sept 2015: This doesn't seem to work any more.

There's a better way. If you edit the search string in the Preferences, you won't get autofill results. If you do it this way, you will.

Change Chrome's Search Engine to Google.com: http://googlesystem.blogspot.ca/2013/07/change-chromes-search-engine-to.html

  1. Type google.com/ncr in the address bar and search for something
  2. Close Chrome
  3. Launch Chrome again, open a new tab and search for something using Chrome's omnibox.
  4. You should see an infobar that asks you: "would you like to search with google.com instead of [your local Google domain]?"
  • Thank you. This almost looks like dark magic. I couldn't convince Chrome to use google.com while still providing suggestions until I found your answer. – sker May 7 '15 at 16:53
  • Unfortunately, this doesn't work any more. – skolima Sep 23 '15 at 16:39
  • @skolima: agreed, doesn't seem to work now. – Simon Woodside Sep 24 '15 at 18:00
  • This worked for me! – Ammar Alammar Dec 29 '15 at 16:40
  • @AmmarAbdulaziz I can't reproduce. What version are you running, what OS, what country are you in, and are you logged into google? – Simon Woodside Jan 4 '16 at 3:17
0

As far as I know, the URL provided in the answer marked as correct has limited functionality. Specifically, user may find it does not trigger search suggestions, etc.

So here's an answer to solve that, which also provides more comprehensive instructions for those who are not familiar with such things.

UPDATE My intent was to post a URL that was reported elsewhere to provide auto-suggestions and force the omnibar to google.com domain. But I have now found none of the suggested URLs provide auto-suggestions. I will, however, leave the below instructions, as they may come in useful for people who want detailed info on how to add a new entry to the omnibar search, for locking in google.com domain.

There is also a better option below, using an extension.

  1. Bring up Google Chrome Settings (Preferences on MacOS, acccessed easily with COMMAND-comma)

  2. In the Search section, click Manage search engines...

Manage search engines button

  1. Scroll down the list of Other search engines to the bottom. You'll see the option to Add a new search engine

Add search engine

  1. Call it something like Google NCR, or anything that makes sense to you. I suggest not calling it Google in order to avoid possible confusion later.

  2. Use the following URL: https://www.google.com/search?q=%s{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:bookmarkBarPinned}{google:searchClient}{google:sourceId}{google:instantExtendedEnabledParameter}{google:omniboxStartMarginParameter}{google:contextualSearchVersion}ie={inputEncoding}

The above link was meant to provide search suggestions too. But it doesn't. So you can just use the simple URL mentioned in other answers, namely, https://google.com/search?q=%s

  1. Once you've added the new search option, you'll need to locate it in the list of Other search engines and hover your mouse over it, then select Make default

Make default

(In the above image the mouse is hovering over the first engine option in the list, just for illustration purposes)

That's it. Should be done.

A better option to force NCR (no country redirect) in the omnibar, with auto-suggestions

There is a Chrome Extension that does exactly what's required. It will force the domain to google.com and all other omnibar functionality will continue to work (such as auto-suggesions, etc.) It's available here.

-1

I've found a new way and it is relatively simple.

  1. Go to your google.com.?? page.
  2. Click on the link on the lower right corner that says use www.google.com
  3. Do a search not from the Omnnibox but from the search bar in the page.
  4. Do another search but now from the omnibox.

As soon as you do so, you will see a message asking if you want to use www.google.com as your default search engine or not. Choose google.com and you're done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.