4

I'm trying to play a video in VLC using command line, but I don't want it to play in full size. I trying to pass width and height as instructed at http://wiki.videolan.org/Documentation:Play_HowTo/Advanced_Use_of_VLC#Video_options but it does not change the appearance of the video -- it is still played in its original resolution. What am I doing incorrectly?

Here's the command I'm using:

/Applications/VLC.app/Contents/MacOS/VLC --playlist-autostart --video-on-top --width=400 --height=400 ./2013-london-snow.mov

As I understand their online documentation is outdated. Maybe someone could point to the source code of command line interface.

2
  • Have you tried man vlc? Or vlc --longhelp --advanced?
    – terdon
    Commented Jan 21, 2013 at 15:47
  • Thanks, looked up but none of the mentioned ones (--width, --height, --scale) appear to be working.
    – jbasko
    Commented Jan 21, 2013 at 15:58

2 Answers 2

0

Try adding --no-embedded-video --no-autoscale.

1
  • This does make a small video window but it leaves a giant empty VLC container window behind it Commented Feb 19, 2022 at 7:15
0

I have tried this too, but in VLC version 3, I couldn't get it to work.

The new beta version 4 (nightly builds) can process the --width parameter and resize the vid. I did notice that it only responded to the --width=xxx parameter and calculate the height according to its ratio.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .