It started happening after I installed the Helvetica font on my system (at least I think that was the trigger).

I tried to install Helvetica on my Ubuntu 12.10 system but the font viewer crashed when I clicked install.
And since then all sans serif fonts are rendered like this in Chrome and Firefox:

enter image description here

I was able to replicate the issue in LibreOffice earlier by switching to the Helvetica font. But currently I'm not able to reproduce it anymore. I also can't find the font under the normal directories to remove or delete it.

It seems it only happens when it's trying to render the Helvetica font family, but no Arial or any others

I've also already cleared the font cache


The font you are linking to looks like OpenDyslexic. Have you installed that font?

In any case, try refreshing your font cache:

fc-cache -f -v 
| improve this answer | |
  • I've already cleared the font cache and I haven't installed any fonts other than Helvetica onto my system – lifeliver Jan 21 '13 at 21:09
  • Does this also happen if you log in as a different user? How about after reinstalling some font packages (sudo apt-get purge msttcorefonts; sudo apt-get install msttcorefonts)? – terdon Jan 21 '13 at 21:13
  • 1
    I solved it by putting a truetype file with the same name into the proper directory, clearing the cache, and then deleting it and clearing the cache again, i guess it just overwrote the previous system entry for the helvetica font or something – lifeliver Jan 21 '13 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.