I have a dual screen setup with two AOC e2450Sw monitors connected to a laptop. The laptop has one HDMI and one VGA output. When one of the monitors is connected using VGA, it flickers or displays static noise. The flickering is fairly subtle and only visible on darker colors. But it is there and noticable and appears like horizontal lines.

The problem only appears on the monitor connected to the laptop using the VGA cable. If I swap the monitors, the one connected using VGA is displaying the flicker but not the one connected using HDMI. The simple solution would ofcourse be to connect both monitors using HDMI, but since the laptop only has one VGA and one HDMI out that isn't possible. I've tried tweaking the monitor setting using the OSD menu, but it had little or no effect.

Update: After several more trouble shooting hours, it seems the problem is not related to the monitor or VGA cable as the problem persists even if I swap the display with another brand and different cables. So it may be the graphics card? Intel HD Graphics 4000. The laptop is Acer Aspire E1-571.

Update again: Another laptop of the same brand in the office didn't exhibit the same trouble wrt the VGA port. I never found out what the source of the problem was. But I suspect that it was something with the particular laptop I was using and that the problem, whatever it was, only affected a minority of all Acer Aspire E1-571 laptops.

  • 1
    HDMI and AV cable connection to monitors are notorious for picking up static. They are not nearly as well shielded as a VGA cable. Have you noticed the heavy square blocks of non-ferrous metal at the ends of most of the better cables? They are their to cut down on the noise, but are not a substitute for good shielding. You can try separating your monitor cables from any other cables around to help with the noise, and if you have the square blocks -- put them as close to the ends of the cable as possible (rob some more from spare cables and try adding them...) Apr 21 '15 at 7:35

I would say that either the VGA cable or the VGA connector on the laptop is damaged.

Have you another cable you can try?

Also try screwing in the cable at both ends to eliminate any movement.

Remember that VGA is an analogue format and so some flickering may occur, the quality of the signal is highly dependent on the connection and the quality/length of the VGA cable.

With HDMI, the signal is digital and so the output is far less dependent on the cable quality.

Oh, one other thing. Even with a good VGA cable, the monitor will probably not be able to do as good a job as with HDMI, especially at really high resolutions - what resolution are you using? That's because the analogue signal has a limited bandwidth.

  • I guess the VGA connector on the laptop may be damaged. But it's brand new and it is not visibly damaged so it seems like a long shot to me. Jan 22 '13 at 16:36
  • What resolution are you trying to achieve with the VGA output? Have you tried a lower resolution to see if the flickering is any better? Is the flickering bad enough to video? Perhaps you could post a video if so. Jan 23 '13 at 21:36
  • The flickering is the same no matter the screen resolution. It's not bad enough to video record. Jan 24 '13 at 9:24
  • Ah, when I read your last comment, another thought came to mind. What lighting do you use? Some lighting can make the inevitable slight flicker on VGA output seem worse? Old fashioned incandescent lighting is "best" as it doesn't really have a flicker whereas fluorescent lighting is the worse. If not that, then I think we've eliminated everything except the graphics output of the PC so I'd have to conclude the there is either something wrong with it or it has a poor design. Jan 24 '13 at 21:25

I had the same issue with Lenovo T430 with dual video (intel and nVidia NVS4200). Flicker has gone away when laptop was forced to use discrete graphics only by disabling nVidia optimus technology in BIOS settings, and setting start up with discrete graphic controller.

  • How is using discrete graphics enforced?
    – suspectus
    Oct 24 '15 at 10:41
  • @suspectus Disabled nVidia optimus technology in BIOS settings, and set start up with discrete graphic controller.
    – Cyrill
    Nov 3 '15 at 10:41
  • Thanks for the update - you could enhance your answer by adding the info provided.
    – suspectus
    Nov 3 '15 at 10:56

You may try a shorter cable. It seems that the integrated graphic card does not send powerful-enough signal.

I had similar problem with 5 metres long cable - once connected to integrated notebook D-Sub port, display flickered; once connected to PC (with graphic card, over DVI-VGA converter), everything worked.

Same setting but with shorter cable (2 metres) worked with both PC and NB, so I suspect the integrated graphics…

  • Sorry But I have tried,VGA TO DVI TO HDMI solution,and it's not going to work,The reason is the VGA is analog and HDMI is digital,so the signal most be converted.
    – Hbirjand
    Apr 21 '15 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.