Eudora Windows 7 MAPI working

I'm just trying to figure out how to get MAPI working enough for the sole purpose of linking all my existing Eudora emails to a GMAIL account. I don't need any other application interaction, and later I can manually switch the MAPI files back to Windows. I finally ensured that I can freely copy mapi.dll and mapi32.dll to/from the EUmapixx.dll I am running Eudora AS an admin with the UAC prompt, but, still can't coax Eudora to allow me to enable MAPI.

I also copied over the MS MAPI32.dll and so now I have all the proper MAPI files in win\sys32.

I also shut down Eudora, modified the Eudora.INI file for MAPI / POP to be 1 0 instead of 0 1 and it STILL won't see that I chose MAPI already in the INI file when I start Eudora !

I only have TWO last things to try --- to change the permissions temporarily on the win32 folder, and then also I will set MAPI on an XP Machine, and use THAT INI instead to see if it recognizes that MAPI is on in WIN 7.

FYI - Although I have YET to get MAPI to work, I HAVE successfully changed the files out, and HERE is how you can allow the MAPIxx.DDL files to be changed OUT. But, don't forget to put the original Windows files back or you will likely break other Office Apps, at least:

FROM: Adding Eudora to Windows 7 "Default Application" list

How to fix the error message - When Eudora starts in Win7, it displays the error dialog "Could not install Eudora MAPI because MAPI.DLL and/or MAPI32.DLL could not be renamed", followed by the error dialog "Eudora was unable to update the system registry. Your default mail program was not changed.".


Answer to Q2.

I had to grant myself permission to the mapi.dll and mapi32.dll files and then run the sweudora.exe program (which sets up Eudora mapi setting). Here is how:

1 Open an administrator command prompt by typing cmd into the start menu search box, and hit the Ctrl+Shift+Enter key combination. 2 To take ownership of the files, you’ll need to use the takeown command.

3 takeown /f C:\Windows\System32\MAPI.DLL

That will give you ownership of the files MAPI.DLL, but you still have no rights to delete or modify the permissions of it.

4 Now run the cacls command to give yourself full control rights to the file: cacls C:\Windows\System32\MAPI.DLL /G geek:F

Note that my username is geek, so you will substitute your username there.

5 Repeat this procedure for MAPI32.DLL 6 Now run sweudora.exe program

(( NOTE -- FYI -- running SWeudora.exe ALSO failed when I ran this as an ADMIN, so... ))

  • 1
    When you find the answer to your own question, it is better to post an answer, rather than updating your question with your solution. You also get the benefit of two sets of reputation. *8') – Mark Booth Jan 22 '13 at 20:03
  • I wish I did have an answer, which I don't. The "solution offered" only solved enough for the first part, and I still can't make MAPI work yet. I will post the results of my next steps. – DaaBoss Jan 24 '13 at 23:26

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.