43

TightVNC allows us to make a remote session full-screen, so that the remote screen takes up our entire monitor.

Under Windows XP, to "restore" (un-maximize) a full-screen session back into a windowed session, we would hit Alt-ESC (or the Windows key) to display our own taskbar, and then right-click on the TightVNC Viewer's taskbar icon where the pop-up menu would have a "restore" option. This entire pop-up menu appears to be gone under Windows 7. The only choice now is to close the session, but it remembers to show all future sessions in full-screen (!).

One nuisance caused by this problem is that I cannot drag the remote session onto my second monitor. Another is that I can't get to the Viewer toolbar and start a file transfer.

Is there a way to exit full-screen under Windows 7 with TightVNC Viewer?

Or, how can I reset this stored value so that I can see future remote sessions in a window?

83

To exit TightVNC's full screen on Windows 7:

Press all four keys: Ctrl + Alt + Shift + F

5
  • 4
    This is not working in the Java Viewer. I found no solution but to reset the preferences entirely (by deleting the appropriate glavsoft registry key) - Win7+Java7 – snorbi Jul 2 '13 at 10:22
  • Thank you! I cannot seem to remember this one on my own... – sjas Jul 16 '13 at 10:55
  • 1
    This is still valid in Windows 10. – kayleeFrye_onDeck May 14 '16 at 1:38
  • This also applies to TurboVNC and Windows 7. – texnic Oct 7 '16 at 9:54
  • Can't send that key combo. Guess I'm screwed? – A__ Jul 7 '20 at 23:40
7

Press F8

"You can enter and exit full screen mode using the toolbar at the top of the VNC viewer window. The F8 key can be used to hide and unhide this toolbar."

https://support.realvnc.com/knowledgebase/article/View/376/12/how-can-i-enter-and-exit-full-screen

3
4

And... to force any future session to be windowed rather than full-screen:

Start TightVNC Viewer and enter your remote address, but before hitting the Connect button, open the Options dialog and de-select the Full Screen checkbox.

2

If you hover your mouse near the top of the screen in the middle, a menu will pop up with the full screen button on it. Click again to get out.

1
  • 6
    Doesn't happen for me. – Luigi Plinge Apr 25 '16 at 9:32
1

Press the Start button, click once on the taskbar, move your cursor to the vncviewer to get the aero peek, right click in it and deselect Full screen. Voila!

0

I also had this problem - I was using TightVNC in another VNC session - so no control key presses went through. My solution was the following batch script on the host running the VNC Server:

net stop "TightVNC Server"

net start "TightVNC Server"

Which disconnects you immediately and lets you connect again.

1
  • Wouldn't using the shortcut keys from the accepted answer be better (and safer, in case the server doesn't start again)? – I say Reinstate Monica Aug 19 '17 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.