41

I change settings a lot. Now, I think I've played with Notepad++ too much. Now how can I reset the settings ?

btw, I don't want to uninstall, then install again. that's not so "superuser"-ish, right?

56

The easiest way to reset to defaults would probably be to delete the configuration files. This also means you can back them up if you ever want them back.

Notepad++ uses the follwowing path for settings using a default installation settings:

%APPDATA%\Notepad++

In that directory there are several .xml configuration files. Remove the ones you want to reset and restart Notepad++.

5
  • This worked great with notepad++ version 6.5.4
    – avanderw
    Jun 30 '14 at 11:47
  • 2
    This is a more useful path: C:\Users\%UserName%\AppData\Roaming\notepad++
    – Ed999
    May 27 '16 at 15:47
  • Removing the 'config.xml' resets it to default layout.
    – Abhijeet
    Oct 9 '20 at 4:43
  • @Ed999 The accepted solution worked perfectl out-of-the-box for me, I don't see what your suggestion adds.
    – avia
    Aug 24 at 9:20
  • I expect the suggested solution works well enough for some users, and may even work for version 6.5.4, but to locate the necessary folder using Windows Explorer it's necessary to know the actual location of the folder. And it helps to differentiate the folder from any backup folder the user may have set in 'Options'.
    – Ed999
    Sep 11 at 5:05
9

Go to

C:\Users\Administrator\AppData\Roaming\notepad++

(type your username instead of "Administrator" in the above path)

Delete the file "stylers.xml".

Restart Notepad++

2
  • 3
    The answer is right. Just always remember about environment variables. %appdata% makes life all of us easier ;) Feb 11 '14 at 16:04
  • 1
    Weirdly enough this turned everything orange for me. Nov 12 '18 at 5:57
1

It is easy to do using the following steps:

  1. Go to settings
  2. Go to style configurator
  3. Then you can see there is an option call select theme.
  4. Select default theme and save it.
  5. Close the notepad and restart.
2
  • 1
    This doesn't answer the question (until there is some Woo-Doo action behind this)
    – nixda
    Jul 12 '13 at 9:50
  • This was immediately useful. 3 seconds versus all the labor involved in every answer above it.
    – Ken Ingram
    Sep 4 '20 at 2:41
0

The following worked for me to remove all color styling:

  1. Ctrl-A to select and highlight entire document
  2. Right click
  3. Remove style
  4. Clear all styles
0

Just in case someone has the same issue as me: If you have a Backupfolder set up in Options you have to delete the files mentioned above from that folder!

-2

just backup config.xml and than erase it to bring defaults back..

1
  • This answer does add nothing new in comparison to the above answers.
    – zx485
    Apr 29 '20 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.