I recently created a small office network with 10+ computers. 9 of them are desktop computers so I used Ethernet cable to connect them.. The computers are connected to a switch via a patch panel and to a wifi router for internet access. All of these computers are connected to the same work group and sharing public files are enables. all sharing functions are enabled and every one can see each others computers over the network.

But the issue is with the one laptop that is connected over wifi to the network. The laptop lists some of the desktop computers that are in the LAN but not all. I used run command and gave the path to a non listed computer and it shows up very well. but the thing is, I need to list all the computer in the network places.

what should I do to this issue.

Laptop OS : windows 7 wifi router : dlink

stock settings with wifi password.

  • Are all the desktops connected to the exact same device? Is there any pattern to the machines you can't see? Are you sure you only have one router in your network? (For example, your modem might have a built-in router and you also have a Wifi router.) Double check to make sure client isolation (sometimes called AP isolation) is disabled in the WiFi router. – David Schwartz Jan 23 '13 at 6:59
  • the desktops are all connected to the same switch and from that switch to a dlink wireless 4 port router. there is only one router in my network. no modems. The thing is, I can connect to the network computers through run command. "//computer-name/" command. but they are not listed in the network places in windows 7. – Imesh Chandrasiri Jan 23 '13 at 7:02

Is the wireless router a standalone wireless router or an access point? If it is a wireless router, it is possible it is not providing access between the laptop and the rest of the network. If you want to keep it this way you'll need some extra configuration.

  • Any hint on what this extra configuration may be? – Kamil Maciorowski Jun 21 '18 at 23:16
  • I'm not sure what router the OP has, so maybe changing operation mode? – Shadowcoder Jun 23 '18 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.