44

I have a windows 8 laptop. My desktop background is very dark (almost black) and when i have no windows open, my brightness dims. When i open an application that is primarily white (google chrome's start page) or just a white image, the screen brightens. It seems to be caused by the color of the screen. If i open http://www.fanhow.com/images/1/10/Green_Storm_Fill_Black_Color.jpg and zoom in and out, when the black image is small, the screen brightens, when it gets bigger, the screen darkens.

I have most likely ruled out "Adaptive Brightness" because I do not have an ambient light sensor.

Is this a feature?

  • 2
    What brand of laptop do you have? I know the Dell I'm using also has an adaptive brightness, regardless of the fact it does not have a light sensor. It just changes brightness of the screen depending on how much white/black is shown at that moment. Whenever I switch from a very dark to a very bright website I notice and increase/decrease in screen brightness. I'm running Windows 7 by the way. – Matthias Jan 23 '13 at 7:24
  • That is the same with me. Is this a feature? – agz Jan 24 '13 at 20:27
  • I believe it's a feature on some screen models, yes. – Matthias Jan 25 '13 at 14:25
  • 1
    This article lists the 3 types of adaptive brightness in Windows 8 & 8.1. You should disable them one-by-one (and reboot) to totally rule-out adaptive brightness. – harrymc Nov 29 '13 at 19:44
  • You might find something useful in superuser.com/questions/187302/… – LSerni Nov 30 '13 at 0:21
45
+50

Short answer: It is a feature.

This is the effect of either Intel's "Display Power Saving Technology" or AMD's "Vari-Bright" feature, the intent is to reduce power usage by reducing brightness when you look at dark images (which ostensibly would not need to be back lit so much). This technology detects whether the screen is displaying a mostly dark or mostly light image, and adjusts the back light accordingly. Unfortunately this can be annoying if important parts of the UI are light colors (like Chrome), or when dealing with highly visual applications (Photoshop, Media, etc) where changes to brightness have a negative effect on visual fidelity.

So yes, this is a feature, unfortunately this means either dealing with the effect, or forfeiting the power savings it produces.

If you dislike this feature, it can be disabled (or adjusted) it in the settings for your graphics card.

Intel:

The exact layout of Intel's options may vary from system to system, but on my machine:

Intel system tray icon > Graphics Properties > Power > On Battery > Display Power Saving Technology

It shouldn't be too hard to find, even if it isn't in the same place on your machine. You may need to look for the properties in control panel.

AMD:

Open the Catalyst Control Center (search for "CCC" in start, choose CCC - Advanced) > Graphics > Power Play > Enable Vari-Bright [Check-box] [Source]

  • I have AMD, not Intel hardware, and I encounter the same thing. (See my comment on the question) – gparyani Dec 2 '13 at 17:31
  • 1
    @gparyani I did a little research and AMD has a very similar technology (which I have edited my post to address), you may find this helpful: h10025.www1.hp.com/ewfrf/wc/… – zeel Dec 2 '13 at 19:11
  • 2
    This "feature" perplexes me. One, I thought it took more power to light up bright pixels. Part of the reason so many mobile apps go with dark themes, and why low power modes typically default to a lower display brightness setting. So, pushing more power to the screen to make the most battery draining images drain even more battery, and pushing less power to the screen during periods when it's already using less power, seems counter productive to being a "power saving" feature. Two, it's just plain annoying to jump back an forth between too dark to see and blinding deer in the headlights. – DiggyJohn Feb 3 '17 at 13:57
  • @zeel thank you! this is the only correct solution! it worked for me (amd) – mathreader Oct 27 '17 at 19:54
  • I have Intel, but in the Power menu (in the Graphics Properties box), there isn't an option for On Battery, or for Display Power Saving Technology. – Cullub Mar 8 at 14:57
10

The answer is correct but unfortunately unhelpful for when your laptop is plugged in, as Intel doesn't allow you to change the setting for AC power. Here's something else to try.

The registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 should have a value named DCUserPreferencePolicy.
Contrary to its name, it seems to affect the AC behavior as well.
I think the top half of the number is for AC power. So you might have something like 0x00220020. The bottom 0 means this feature is disabled for DC power, so I think changing the upper half to mirror the lower half (that is, to 0x00200020) should fix it. In my case, I just set the whole thing to 0 because I didn't particularly care what it was. You can try that or something else.

  • 1
    Wow, thanks a lot. This was really bothering me. – MichaelGG Oct 4 '15 at 20:58
  • This worked for me after restarting the laptop, thanks a bunch! – marc Jan 13 '16 at 20:43
  • Dell E5540, I have the changing brightness issue. The value indicated in this answer was already set to 0, so no luck. – bg17aw Aug 28 '16 at 17:46
  • This worked for me on a Lenovo W520 where the issue appeared suddenly a few days ago, presumably after a driver or Windows 10 update. Setting it to 0 seems to be fine, the ACUserPreferencePolicy was at 0 already in my case. – JulianHzg Oct 9 '16 at 19:19
  • Thanks! After many tries this has finally worked on my laptop. – rslite Nov 30 '16 at 3:17
4

The provided solution addresses the issue but my computer did not have the intel system tray icon, but I found I could also access the configuration by right clicking on the desktop and choosing:

Intel® Graphics Settings →
 Graphics Properties →
  Power →
   On Battery →
    Display Power Saving Technology
  • zomg THANK YOU SO MUCH! This thing was driving me nuts and searching for "Intel" in the start menu (win-key + s) was finding nothing. I finally have a normal display without this retarded "feature". – RVP May 19 '18 at 15:10
2

My laptop does exactly the same thing. It's a display panel "feature" (not Windows 8 fault), Dynamic contrast . Maybe a badly implemented one.

  • 2
    how to disable it? – Lakshay Jun 1 '15 at 5:13
  • @Lakshay as with most things hardware-related it depends on what the manufacturer was thinking. Maybe it's a setting on your video-card configuring application, if you are on a laptop. If you are on a desktop maybe there is some option on the monitor on-screen menu. Maybe it's fixed and can't be disabled. – NothingsImpossible Jun 3 '15 at 20:05
  • I doubt this is a feature as it would clearly be marketed as such. The link might be misleading, as it is about a technology in general and there is no info it is implemented on laptops – bg17aw Aug 28 '16 at 17:47
2

Sometimes it is the Monitor's settings (the physical menu button on monitor) go into color and change DCR mode to off

  • The question is about laptop screen – bg17aw Aug 28 '16 at 17:37
  • 1
    My extended display was monitor and I had to turn off setting from its control panel. – Amit Bhagat May 13 '17 at 2:58
  • 1
    After trying everything here, this turned out to be the problem. Not only that, but there was no configuration in the settings! I had given up and tried to just peg out the brightness to make the best of things and when I tried to manually adjust it, it told me it would have to disable automatic dimming! – Präriewolf Jul 13 '17 at 13:39
  • On my Samsung SyncMaster P2470, setting MagicBright to "Dynamic Contrast" will automatically adjust brightness and contrast based on screen content. Changing this fixed the issue for me. – christophem Dec 2 '17 at 21:15
  • My screen was driving mad and tried @Präriewolf move in my LG Flatron L1952HQ. No message on disabling automatic dimming but touching the brightness and contrast up and down (leaving the same value) fixed the issue. Why this begun? No idea. By the way, the question has indeed the word laptop in it but I think it's more about the brightness change; maybe it would be good to remove the laptop from it. Fortunately, thedrs leave us the answer in our case. Thanks everyone. – cdlvcdlv Dec 31 '17 at 16:29
2

To solve this issue: I disabled Display Power Saving Technology, located in Intel HD Graphics Control Panel, Power, On Battery. At first the problem persisted, but after unplugging AC power from my laptop and reconnecting it, the problem was solved. There's no option to disable this "feature" for AC power, and I was unable to find anything in the registry. So, disabling the setting for battery power is the solution, it just requires the laptop to be cycled from AC-DC-AC. My eyes are grateful :) Hope this helps

0

I didn't try the registry key thing, but I tried everything else mentioned here and elsewhere (Control Panel/Change Advanced Power Settings/Display/Adaptive brightness -Dimmed brightness, Intel icon etc..) Nothing worked. Than I unplugged the laptop and when Windows asked me to switch to power saving, I've hit NO. Then I plugged it again and it's back to normal. My display brightness was varying with the image( darker image-dimmed brightness) and it happened after I used the laptop unplugged and Windows changed to power saving.

  • How does this answer the author's question? – Ramhound Jun 23 '16 at 22:52
  • @Ramhound this answer offers a solution to disable this behavior which in itself suggests it's a feature. So it is a helpful contribution – bg17aw Aug 28 '16 at 17:39
  • It is indeed a helpfull contribution. I myslef have noticed the exact same thing. The "feature" appears when the laptop runs on power and then remains even when you plug it back in – laertis Feb 16 '17 at 9:42
-1

If nothing helps anymore, u can try this: After all changes in your configuration have been tried, do the following: Start your laptop on battery current, then when the OS is showing it's desktop, switch to the AC current. Your laptop senses that you switched between the battery and AC and will not adapt your screen anymore, not even a dark screen getting darker. Mind you, you have to do this every time you start up, even when your laptop was in suspended or sleep mode. It helps me a lot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.