I have just solved the Bad Pool Caller/Header BSOD bug (after corrupt Kaspersky installation). At the same time when the BSODs started to pop up my internet connection stopped working. I use WiFi and it displays that the connection is working.

No web browsers can display pages. Chrome suggests changing the proxy settings (they are at default). Metro apps don't work either (but the mail app is working just fine - at least the gmail account).

I made a disk check and it found and fixed 1 error. I performed a clean boot (but I'm not sure if I did it correctly).


What errors are being displayed when you attempt to browse a website?

Since you are using an HTTP Mail app like Gmail then that rules out a problem with your computer being able to send and receive HTTP traffic, it also rules out any issues with your internet connection. Especially seeing as how you said your network settings say the wireless network is functioning correctly.

That means that you you are having an error that has something to do with your web browser specifically. I could go into more depth and do some research on what exactly may be causing it but to be honest the easiest thing to do first in order to rule out browser issues is to first try using Internet Explorer and or Firefox or some other browser. If that works then you have a specific issue with Chrome and I would recommend you un-install it and re-install it.

If none of you're browsers are working then we can move on from there. Comment and let me know if you have done this yet and I will try and help you figure out a solution.

| improve this answer | |
  • I tried this with MS IE, Chrome and Firefox. They all display the standard message about the inability to load the page (check if the address is correct etc.) Also every single internet accessing application cannot access it (inlcuding Windows 8 Store, News, MS Outlook). Only the Mail app works (I have no idea why). I have numerous programs which use the internet connection in some way but they all dont work. Im sure that this isnt the case of the browser or any other app. There is something specific with windows settings. Also I tried disabling the windows wall and it didnt solve the problem. – BuahahaXD Jan 23 '13 at 21:07
  • Reboot the System into Safemode with networking and try to access the internet. If that works do a Cleanboot following these instructions: support.microsoft.com/kb/929135 – Kentgrav Jan 23 '13 at 21:19
  • 1
    Too boot into safe mode follow these instructions: windows.microsoft.com/en-US/windows7/… – Kentgrav Jan 23 '13 at 21:21
  • Found someone with a similar issue here: answers.microsoft.com/en-us/windows/forum/… – Kentgrav Jan 23 '13 at 21:26
  • And here is someone else but the answer appears to be somewhat the same, maybe it can help. Try to do what they said which starts with the cleanboot like I said before and let me know if you still can't get it fixed. answers.microsoft.com/en-us/windows/forum/windows_8-networking/… – Kentgrav Jan 23 '13 at 21:28

I fixed the problem. I had to enter the settings of my wifi connection and turn off Comodo Agent or something. It caused all the problems. IPV6 wasnt working.

Thank you for your effort in solving it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.