I have just installed Fedora 18 KDE spin on my HP Pavillion dv6, but I have one problem: the brightness of the laptop is stuck at the highest; I have also two button that allow me to change the brightness, but when I click them a small window appears saying that the brightness is changing, but in reality nothing happens. How can I solve it?

If it helps, here is the /etc/default/grub file:

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.keymap=it2 rhgb quiet$

Try adding "acpi_backight=vendor" to the end of the GRUB_CMDLINE_LINUX argument. The Linux kernel tries to control the backlight, but does a very poor job with some laptops. That kernel argument hands control of the backlight back to the vendor hardware.

The problem I have on my dv5 is that the backlight doesn't turn on at all without that argument. Not exactly the same problem you have, but it might be related.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.