0

I just bought my first VPS that I got a smoking deal on.

It is running Ubuntu 11.10 X64.

I set up a Minecraft server on it to see how it would handle it, and ending up created a minecraft account on the VPS to run the MC server at boot.

Now I would like to log in to the minecraft through SSH so I can screen the minecraft server. But I am unable to SSH into my VPS using the minecraft account I created. When I enter the account's correct password it immediately closed the SSH session (if I enter the incorrect password it tells me access denied).

I can SSH in with root still.

I have

  • made sure the minecraft account has a home folder and appropriate privledges to it.
  • edited the sshd_config file, adding a AllowUsers field for minecraft and root
  • edited the sshd_config file, setting UsePriviledgeSeparation to no

migrated from stackoverflow.com Jan 23 '13 at 23:20

This question came from our site for professional and enthusiast programmers.

0

maybe the user has /usr/sbin/nologin ? In any case, make some attempts and then check /var/log/secure to see what's wrong.

I belive you can change user login or nologin in /etc/passwd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.