I've recently installed a Tenda TEG1024D 24 Port Unmanaged Gigabit Switch in order to phase out the additional 8 port 10/100 Mbps switch which was connected to a Netgear ADSL router. There is one computer that hosts both the mysql server and shares files to the rest of the clients on the network. There were no problems before i replaced the 8 port switch however since the Gigabit was installed, i'm having major issues:

  • The clients can't access the mysql server
  • The clients can't access the shared files


  • All the computers are assigned correct IP addresses AND

  • All the computers including the server can connect to the internet.

What could be the problem?

  • Is it possible that the Gigabit switch is incompatible with my ADSL router or vice versa?
  • I'm using cat5e cables, would that matter?
  • The ADSL router is pretty old, one of those small white netgear ones.

Please help,

much appreciated,


  • Not likely. No. Shouldn't matter. Can PCs ping each other? When you get desperate: Disconnect everything. Set up two PCs with static IP addresses. Connect both to the switch at various ports. See if you can ping the other PC. The switch should function without a router attached. – sawdust Jan 26 '13 at 7:38
  • Most new networking gear is "smart", incorporating VLANs, routing, perhaps even firewalling. Check the configuration carefully, check conectivity with ping and tcping – vonbrand Jan 26 '13 at 7:45
  • @vonbrand OP new switch is unmanaged, so there cannot be vlan and other features. Can't even be ping. – John Siu Jan 26 '13 at 8:12
  • @CraigWayne (1) Reboot the server if not tried yet. (2) Can client ping the server and vice vasa? – John Siu Jan 26 '13 at 8:15
  • Thanks for the replies everyone. I have tried pinging. Doesn't work. Initially when I connected pc by pc. It works. But somewhere along the line it just bombs out. Does it matter that I mix cat5 with cat5e cables. Some PC's use cat5, and some cat5e. I'm going to try isolate the problem and post back. Thanks again. Oh one more Q, is there. Minimum requirement for the length of cat5e cable? – Craig Wayne Jan 26 '13 at 13:47

when you plug a computer into the switch you should see the link light LED come on (assuming pc is powered up) and you should also see the 100/1000mb LED light up, one colour will indicate it has negotiated 100mb speed, another will indicate 1gb speed. If you dont get a link light then either your cable is faulty or the network card in the pc. Try another port on switch just incase it is a duff port. Also make sure you havent accidently plugged both ends of the same cable into the switch which would cause a broadcast storm and result in network outage.

  • Thanks for the suggestions! :) going to make sure. Only get back in on Monday though, fingers crossed. – Craig Wayne Jan 26 '13 at 13:51
  • I'm sorry for not getting back to this post, been really busy, but you were right @blaze451 , i had plugged both ends of the same cable into the same switch. DUMBA$$. Thank you though :) never take things for granted! – Craig Wayne Feb 1 '13 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.