0

I have a device with RS-232 and a control program on PC. It works fine via serial cable but with usb-to-serial some functions don't work correctly.

Why usb-to-serial doesn't work?

I tried to change Tx and Rx and install official drivers for this adapter, but it didn't help. Also, I tried serial port monitor - on the face of it, everything is equally between serial port and adapter.

1

USB->Serial adaptors have a higher latency due to the way data has to be batched up and sent in packets over the USB. For most things that just stream bulk data, this doesn't matter, but some control processes expect to be able to write a byte and get back a response very quickly, so they don't work.

  • Any workaround there? – jsbueno Dec 15 '14 at 14:53
  • @jsbueno, nope. – psusi Dec 15 '14 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.