I have followed the archlinux beginner's guide thoroughly and was able to install archlinux in UEFI mode and has been able to succesfully boot from it. Everything works fine except that I am unable to boot Windows 8 from GRUB.

I have tried os-prober,as suggested by the Arch Wiki; and when I boot from the menuentry generated by os-prober, it shows:

error: can't find command 'drivemap'.

error: invalid EFI file path.

Press any key to continue...

The following are the commands shown when i press e to edit the above menu entry:

setparams 'Windows 8 (loader) (on/dev/sda1)'

insmod part_gpt

insmod ntfs

set root='hd0,gpt1'

if [ x$feature_platform_search_hint =xy ]; then

search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 5618A11A8A0F9DF


search --no-floppy --fs-uuid --set=root 5618A11A8A0F9DF


drivemap -s (hd0) ${root}

chainloader +1

And I have also tried adding entries manually through /etc/grub.d/40_custom

menuentry "Microsoft Windows 8 x86_64 UEFI-GPT" {

insmod part_gpt
insmod fat
insmod search_fs_uuid
insmod chain
search --fs-uuid --no-floppy --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 5618A11A8A0F9DF
chainloader /efi/Microsoft/Boot/bootmgfw.efi


This is the result:

error: file '/efi/Microsoft/Boot/bootmgfw.efi' not found

Press any key to continue...

Please help!! I'd be glad to provide any additional Info needed!! Thanks in advance!! (do help me edit the formatting above, I'm quite confused by the usage of Blockquotes)

  • I'm thinking that the real problem is that I don't know the path and name of the EFI bootloader of windows. Could you guys just suggest where it could be and what the name of the bootloader is? Jan 27, 2013 at 8:07
  • It's possible that your Windows boot loader has been moved or deleted. Try running the Boot Info Script (sourceforge.net/projects/bootinfoscript) as root in Linux. This will create a file called RESULTS.txt. Post a link to it here; it provides a lot of technical details about partitions and boot loaders that will help us answer your question.
    – Rod Smith
    Jan 28, 2013 at 17:53
  • Also, your question title says that rEFInd can't launch Windows, but your text doesn't elaborate. What happens in rEFInd? Do you see a Windows entry at all? If so, what happens when you try to launch it?
    – Rod Smith
    Jan 28, 2013 at 17:54

1 Answer 1


One needs os-prober >= 1.58 (added uefi support) and grub2 with a patch by mjg59@ attached to https://bugzilla.redhat.com/show_bug.cgi?id=972355 (or debian one, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=698914) so that its helper would slurp what os-prober feeds it now.

  • I'm sorry but I've given up trying a long time ago as I am busy with other stuff. Had reinstalled Windows 8... Anyways thanks for the help I might look into it when I have time. Dec 3, 2013 at 19:20
  • Well, there are at least four distros that can cope with SecureBoot with no extra fuss (I've finished the fourth one recently and am working on the docs on that). In case you'll want to have a look, here's my bunch of ever-fresh weekly images based on ALT Linux: en.altlinux.org/Regular -- I did test win8 dualboot with those. Dec 23, 2013 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.