I connect to my workstation which is a linux box(Red Hat Linux) from a my laptop(windows 7 machine) through RealVNC . When I am work I use a docking station and the resolution of it is quite high and my laptop has lower resolution . So when I switch between my monitor and my laptop I need to restart vncserver everytime with the proper geometry. Searching on the internet I landed on this answer on stackoverflow.com which describes way to assign a different geometry on the fly . The key here is the randr argument while starting vncserver . So the first thing I did is to ensure that Xrandr is installed on my linux box :

which xrandr 

This gives the following output :


Next I tried running the server with the command :

 vncserver -geometry 1600x1200 -randr 1600x1200,1440x900,1024x768

But the server didn't start . Next I started the server with only the -geometry argument and without the randr argument as given in the second answer .

Next from the terminal I issued the xrandr command and got the following error :

Xlib:  extension "RANDR" missing on display ":1.0".

What does the above error mean and what am I missing here ?

  • Are you using RedHat or Linux native vncserver? I've noticed that vncserver doesn't support RANDR. I'm trying to see if there is a way to get it working.
    – wisemonkey
    Commented Jul 18, 2014 at 17:59

3 Answers 3


On my Ubuntu server, it wasn't working either with the -randr parameter, but it works great by using several times the -geometry parameter. Give it a try.

So you would enter:

vncserver -geometry 1600x1200 -geometry 1440x900 -geometry 1024x768

And after, you use the xrandr command to change the resolution.

  • YES! Finally! This works w/ Ubuntu 14.04 + vnc4server 4.1.
    – Jeb
    Commented Jul 18, 2017 at 3:01

I had a similar issue. This gave me the same error:

vncconfig -set RandR="1855x1055"


  1. open VNC server 'Options' dialog
  2. go to 'Expert' tab
  3. find the 'RandR' parameter and set the value as needed!

See Options screen

After clicking 'Apply' you'll be able to resize screen with

xrandr -s 1855x1055

That worked for me, I hope it will help!


I would guess, off the top of my head, that your version of VNC doesn't support RANDR. Are you sure it's supported?

  • exactly. tightvnc doesn't support randr. tigervnc does. replacing fixed this. thanks! Commented Jun 23, 2020 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .