Can someone tell me what that Last BIOS time is on the upper right corner of the task manager on Windows 8 Pro? Mine has always been 0.0. I guess it is not measuring the BIOS time properly so what can I do to fix that? I own the Samsung NP700Z5C-S04US FYI.

Here's a snapshot of my task manager: enter image description here

  • 1
    There were no options to enable/disable it anywhere. But I do have all the programs from Samsung's site
    – Afzal
    Jan 28, 2013 at 20:27
  • You need to verify this information is added by those programs, once you do that, you can direct the question towards Samsung for an answer.
    – Ramhound
    Jan 28, 2013 at 20:39
  • 4
    The Surface Pro has this as well for me. I suppose it has something to do with UEFI and the way it reports back to the OS compared to BIOS. Apr 4, 2013 at 20:49
  • @Ramhound - My machine has this too. I built-it my system with ASUS/Intel hardware. I did not install anything special to get this behavior. I'm running Windows 8.1 Enterprise. Pretty sure this is a built-in feature. Maybe the Home version doesn't have it or something? What version are you running that you don't have this? Nov 19, 2014 at 1:49
  • 1
    @Gaia Thank you for your contribution. If you check the accepted answer, it covers what was mentioned in your answer. The MS-MVP might have actually referred back to the top answer of this question for all we know. And besides that, it doesn't answer the other question I asked, which was how this could be fixed on my device. I do not have an answer for that to this day, even on Windows 10. It would be unfair to not give credit to Karan for the original research done when the question was asked. If there are any other updates worthy of being mentioned, they will be edited into the top answer.
    – Afzal
    Jul 12, 2016 at 20:13

10 Answers 10


Very interesting question indeed! I spent quite some time looking around, and here's what I found so far:

  • It's not just you (that's one of the earliest references I found to this feature, pre-dating the GA release of Windows 8 by a couple of months).

  • It's possible that Condusiv Technologies/Diskeeper Corporation's ExpressCache software is responsible for this, but I'm not sure. From what I can see it's not confined to Samsung laptops, although all other references were to PCs with SSDs, so those may have had ExpressCache installed as well.

    Perhaps you can see whether NirSoft's InjectedDLL detects anything on your system, since I don't know of any other way for a 3rd party to accomplish a Task Manager modification like this besides DLL injection.

  • There's precious little information about this, and no official Microsoft documentation as far as I can see (not surprising if it's not an OS feature). I guess that explains why you received no replies when you enquired about this previously here.

  • The best source of information I've found so far is this TechNet thread, where someone says that "Last BIOS Time" is an indicator that only shows up under some conditions, and someone else says that it displays the time taken to boot up after the PC passes the BIOS screen.

    Unfortunately, no insight into what precisely those conditions might be, or indeed whether it's even an in-built OS feature at all.

  • Very informative! :) Here's the list of DLLs (sabrefresco.dyndns.org/dll.html). WinCRT.dll seems like the only one being launched from a 3rd party directory, so that could very well be why I have the "Last BIOS time" on my task manager. I will accept your answer shortly :)
    – Afzal
    Jan 31, 2013 at 11:54
  • Interesting. This shows up in a lowly Asus X201, which certainly don't have any SSD (though it does boot very fast). It shows 3.8 seconds on it
    – Martheen
    Jun 13, 2013 at 7:54
  • 1
    What's intriguing is that if indeed it's an OS feature, why hide it? No documentation or even official acknowledgement as far as I can see. Since it could be useful, how do we trigger it to show on demand? What are the conditions required for it to show up on its own? Questions, questions... :)
    – Karan
    Jun 13, 2013 at 9:06
  • RE: "DLL Injection", Microsoft Detours seems like it would be able to pull this off without actual DLL injection (since it fakes DLL injection). -- It's used in some production products. The old NVidia Optimus drivers on my Lenovo laptop used it. Nov 19, 2014 at 1:54

Although I'm not sure why you are getting it displayed as 0.0 seconds, the purpose of the "Last BIOS time" is to tell you how long it took to load the BIOS, it is the amount of time between pressing the power button, and seeing the screen that indicates that windows is loading.

  • +1 as to say what I wanted to say, 0.0 is a time taken by no laptop, it indeed does take some time to load BIOS. Jul 25, 2015 at 5:45

Just in case anyone stumbles on this question, this is indeed a built-in part of Task Manager. The string is in Taskmgr.exe.mui and can be seen with the following PowerShell command:

select-string 'last bios time' C:\Windows\System32\en-US\Taskmgr.exe.mui -enc unicode | select matches

this is indeed an OS feature present in windows 8 by default. i have seen it in several Laptops.

From what i make of it, and its a personal observation from having worked across so many different laptop brands and models, its actually the time the computer takes to boot once the BIOS recognizes the win 8 OS to the time you get the welcome screen.

  • Welcome to Superuser. We are not a forum but a community for questions and answers. I've edited your answer to better fit the format.
    – Tog
    Jul 30, 2013 at 19:24

I just noticed it on my M17x-R4 with a clean install of Windows 8 Pro. Mine says 52.9 seconds right now-don't know what that means, as it sure takes less time to boot than that!

I did but an aftermarket Crucial M4 SSD in my system, but I do NOT have any expresscache stuff installed, nor any drivers at all for it. Very few system specific drivers that weren't built in to Windows (basically just Dell/Alienware's software to enable some of the function keys, plus Creative Lab's drivers, plus Nvidia's drivers).

Oh, also my system can boot with either UEFI or an emulated BIOS mode, the latter of which is what I use. Maybe whatever it is doesn't work if you're in UEFI mode, or-Samsung's UEFI firmware is known to be buggy, and maybe whatever this is doesn't work right with it.

I would assume it's an OS feature.


You need a UEFI BIOS with windows 8 installed on a GPT partitioned drive to get it to work.

Also, if your VGA card's BIOS is GOP enabled you can enable "Ultra fast boot" or "hardware fast boot."

My Asus Vivo F202E (Or X202 in US) with my Samsung 840 250G SSD has a bios time of 1.9s. Not bad for a Celeron 847 @ 1.1Ghz.


There is conflicting information online but I will stick to the latest one.

So, here's the usual boot process:

Hardware initialization by BIOS/UEFI <> Windows Boot <> Good to go

"Last BIOS time" supposedly measures how long it takes for the hardware to initialize (i.e. POST) before booting Windows. For some, it may be 0.0 because their specific BIOS/UEFI firmware does not take note of the time it takes to POST. Another reason would be that their PC has a sort of "Fast Startup" feature where the PC completely skips POST and directly boots Windows, as the case is for me.



Conflicting Source


The BIOS time is the time taken before the first beginning screen shown after pressing the power button.

This is the total time you have to press the button (whether it be a function button e.g.f2, esc or del) to help access the BIOS.

The BIOS is a part of the computer outside of the operating system which can show you the 'real life' components of the pc. This can be useful to perform tests on the components themselves and see their properties before the OS has even booted up or shown an image on the screen. It can be accessed by pressing a button as soon as you press the power button.

  • This answer is completely and utterly incorrect..
    – AStopher
    Jan 17, 2016 at 9:28

If Secure Boot isn't enabled but your Windows is UEFI and has a GPT Windows partition this will always show 0.0 as the timer only works with Fast Boot, and Fast Boot is forcibly disabled without Secure Boot(for security reasons)

  • Both of these statements are false. I have a regular PC with Windows 10 installed in UEFI mode and it displays the value, without Secure Boot or Fast Boot. IIRC, Fast Boot also does not depend on Secure Boot.
    – Daniel B
    Jan 11, 2016 at 16:17
  • This is not false, i have succesfully shown the bios time as 2.5 seconds when i enabled fast boot on my older Win8 laptop, and fast boot doesn't work without GPT partitioned drivers. Jul 12, 2016 at 9:17
  • “If Secure Boot isn't enabled...” - not true, works for me. “the timer only works with Fast Boot” - also wrong, works for me. I can’t verify it now, but I also doubt Fast Boot depends on Secure Boot. Of course, the firmware setup may impose unnecessary restrictions. Buggy firmware would also explain it showing “0.0”. That still doesn’t mean any of this is applicable to other devices
    – Daniel B
    Jul 12, 2016 at 9:24

According to a Microsoft MVP, It's the amount of time in seconds between the end of the BIOS screen (windows logo comes up) and the lock screen showing up.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.