I have an Edimax EW-7811UN WiFi dongle which I bought for a raspberry pi. I have not managed to get it to work so am testing on my laptop for easier fault finding and since I know the installation and wireless (with built in adaptor) is working fine.

If I disable the built in adaptor (wlan0) and enable and configure the USB Edimax adaptor (wlan2), it constantly tries to connect. Then it will sometimes manage but then immediately drop the connection and try again.

There is no MAC filtering on the router. Any other device works without any problems. I am using WPA2, if that makes a difference.

I have trawled the net and tried every fix of alternative drivers that I could find.. but still no luck. But most of these are for if it isn't recognised.

Any ideas?

  • Does the dongle work if you disable security of your router? I've had problems with external wifi devices not having fast enough hardware to decrypt WPA2. – Marcus Chan Jan 28 '13 at 19:56
  • Others have the same adaptor working fine with WPA2 so it shouldn't be a limitation of the device. I don't have control of the router so can't remove security. – Mark Jan 29 '13 at 12:08

I have found a link to a page which appears to work on the laptop! Perhaps the key was to configure via wpa_supplicant.conf rather than through the GUI..?

Anyway, for anyone else having the same problem..

Now to try it on the rpi!


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.