Suddenly my USB Flash Drive (8gb Corsaire Voyager) is suddenly read-only, and I'm not sure why.

There is no "read-only" switch on the drive. All of the data is still there. But nothing can be written to it anymore. There are 2gb free on the drive. The OS is Windows7 Pro x64. It wasn't this way yesterday.

In FreeCommander, if I try to create a new folder on the drive, it tells me the drive is write-protected.

I plugged it into a different computer and it is read-only there, too.

What could cause that, and how can I get it back to read/write mode like it ought to be? I know I can fix it by reformatting it, but I don't want to do it that way.

I have found several solutions to do this, but haven't solved it yet:

  • Safely Eject Flash Drive
  • Make a registry edit (the key doesn't exist, however)
  • Add the registry key (that didn't exist) and set the value to 0 (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies set WriteProtect to 0)
  • Reassign the drive letter
  • "Scan and Fix" (check disk dialogue appears when you plug it in) - write-protection prevents this, however.
  • If you right click on the drive and go to security tab, is "allow" checked in the permissions field for "Everyone"?
    – Carl B
    Commented Jan 28, 2013 at 20:46
  • There is no "security" tab in the "properties" dialogue like there is on a regular drive. I think something is wrong with the hardware.
    – bgmCoder
    Commented Jan 28, 2013 at 21:34
  • @BGM-I should have waited for your reply as I answered as if you could get to the security tab.
    – Carl B
    Commented Jan 28, 2013 at 21:40
  • This is NOT a duplicate - that question was asked just yesterday, this question was asked three years ago - the other one is the duplicate. You all can't close my question based on just the title.
    – bgmCoder
    Commented Sep 17, 2016 at 13:25
  • 2
    @bgmCoder YUes we can if the proposed duplicate 1/ answers the question 2/ has better answers than this one :)
    – DavidPostill
    Commented Sep 29, 2016 at 14:14

5 Answers 5


Open cmd.exe as administrator. Then run the following commands:

  1. Type in diskpart.exe and press enter. This will open command line based disk management utility, indicator will change to DISKPART>
  2. Within diskpart, type list disk and press enter. This will show all connected disks. Notice the "Size" column and make a note of the disk # you are concerned with.
  3. Now type select disk X where X is the numerical digit from step 2.
  4. To see its attributes, type attributes disk and press enter.
  5. Now that we've ensured it is indeed a read-only disk, we will need to clear the flag. Simply type attributes disk clear readonly and press enter. This should clear the read-only flag.

Now you can format using diskpart or use Windows explorer to manage it.

  • 6
    My disk is write protected, but both Current Read-only and Read-only states are both No.
    – vinnief
    Commented Mar 29, 2018 at 12:16
  • "Disk attributes cleared successfully." awesome! Commented Jun 22, 2018 at 21:01
  • List Disk does not list my memory stick on my WIn7....?!
    – gilu
    Commented May 3, 2019 at 8:11

The drive is going bad. I've seen this happen to USB flash drives before - they are only temporarily good for storage, and you have to keep them backed up.

To confirm that the drive is bad, whilst copying files from the drive I see that it says certain files that are queued for copying do not exist.

Also, it is marked with write-protection, even though there are no registry entries causing that to be so.

A DOS prompt cannot be had!

Trying to copy files from the drive is nearly impossible.

Time to buy a new flash drive.

  • 2
    I work with hundreds of USB flash memory sticks and I can confirm this - bad drives can show up as read-only. Sometimes OSes can remount a drive in read-only mode when it raises hardware errors - this could be the cause.
    – unfa
    Commented Aug 29, 2018 at 8:45
  • 1
    i had the same problem and i solved with this portrob2.dyndns-ip.com/manuals/usbfixup.html
    – elle0087
    Commented May 11, 2020 at 13:57

What could cause that?

This can happen by pulling the drive without using "Safely remove Hardware and eject".

how can I get it back to read/write mode like it ought to be?

A first check would be to ensure that the permissions are set to allow in each catagory. If it is blank, this could cause an issue for writint to the drive. To check do the following:

You would right click on the drive and select properties. Click on the Security tab and click on Edit

USB 1 Under each Title (Everyone, System) be sure the first box (Full control) is checked.

Click OK. If permissions were the issue, this would resolve it. Usb 2


If something is not working on one of my flash drives then I usually use GParted or something similar (GParted is Linux only, MiniTool Partition Wizard seems good for Windows.) to recreate the MBR and erase all partitions, then I create a new FAT32 partition on it and it usually works again. If your USB is failing due to age, then nothing can help you. Solid state drives (including USB drives) can only function after so many read/writes.

Also, remember to always back up data before messing with the drive's partitions.


I had the same issue, but I tried changing the allocation unit size to default and it worked.

enter image description here

  • 3
    A key word here is "suddenly". The allocation unit size doesn't suddenly change on its own.
    – fixer1234
    Commented Apr 17, 2016 at 19:12

Not the answer you're looking for? Browse other questions tagged .