5

I have been experiencing a problem with VMWare Player 3.1.6

This is on a Panasonic Toughbook CF53 the Host OS is Windows XPSP3 fully updated, The Guest os is Windows XPSP3 fully updated.

It seems that randomly in the guest the mouse cursor becomes completely erratic and uncontrollable moving randomly around the screen. The mouse while uncontrollable in the guest works fine in the host. The only way to fix it is to reboot the guest machine numerous times as the problem may still be there after a reboot.

I have tried:

  • reinstalling the vmware guest tools.
  • updating the hosts's machines mouse driver.
  • reinstalling the host's and guests mouse driver
  • Changeing guests hardware accelation to one from top ( this disables mouse pointer accelaration)

None of the above works. I have been at this for days now. Anyone got any ideas on what to try next. I cannot upgrade to the next Major version of VMWare Player.

4
  • 1
    Does this problem occur only when using the laptop's trackpad? Does it occur using an external mouse connected to the laptop? – Zac B Feb 3 '13 at 19:27
  • Have you tried reinstalling the guest OS (or creating a new VM)? My main use of a virtual machine is to run untrusted software, so malware infection seems a strong possibility. – Hugh Allen Feb 4 '13 at 11:55
  • When you were checking the mouse drivers on the guest, was the mouse listed as VMware pointing device? I've seen VMware Guest revert to PS/2 or HID mice, which means the mouse isn't using the drivers from VMware tools. – Nick Feb 6 '13 at 16:14
  • are you using a graphic card?you can try installing other gfx drivers – swapyonubuntu Feb 6 '13 at 20:42
1

Disable Write Combines in the advanced Display properties in your XP VM.

1
  • 1
    Any chance of explaining what this does or why this might help? – Mokubai Sep 9 '13 at 17:59
0

After Installing the guest OS, I would install the vmware tools also, I didn't see in your notes if you did this. Player Menu: File-->Player Preferences-->Download All Components Now button. If you can't find them there you may be able to download them.

0

I had to undo the VMWare additions.
Edit and add to the following config-file:

  • Windows:   %APPDATA%\VMWARE\preferences.ini
  • OSX:       ~/.vmware/preferences

    pref.motionGrab = “FALSE”
    pref.motionUngrab = “FALSE”
    

Source: http://kasperk.it/vmware/mouse-grabungrab-vmware

1
  • It worked for me, your "mileage" may be "weary" ;) – Magnus Nov 30 '19 at 20:06
0

I had a very similar issue by trying to play Minecraft in a VM (MC Forge Dev Environment in case you're wondering).

I was poking around in the VM options, and it turns out VMware lets you connect removable devices directly to the Guest OS. By directly connecting my mouse to the VM, the erratic behaviour in Minecraft completely vanished.

Now... I'd suggest that you find a spare mouse and connect that directly to the VM, because you're not going to be able to use it in the Host OS.

I found that to be particularly challenging when I decided to not also directly connect the keyboard to the Guest OS. This resulted in a Limbo state where I tabbed out, thinking it would tab out within the Guest, but it tabbed out in the Host. I couldn't regain focus of the VMware window, resulting in a need to fire up Task Manager and kill VMware.

But give it a try. It worked brilliantly for me (minus the keyboard issues which is why I'm going to use a dedicated VM mouse). Let me know your success, and if you have any theories other than "VMware probably gave up control when the mouse went to the edge of the fullscreen, but MC doesn't care about that", then please, leave a comment and let me know

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.