It seems i am unable to find a way how to install lazarus on 64 bit slackware system.

My goal is to make a 64 bit version of my DLL (.so in linux) which was writen in delphi. All is fine in 32 bit system. I use Arch Linux to build the 32 bit version, and using 1.0.2 Lazarus. I can use the .so file in 32bit slackware 13.1 with no problem.

Here is what i have tried so far:

Succesfuly installed 64bit version of fpc (v2.4.0).
Downloaded source codes of Lazarus from svn svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus. Compile failed with "expected := found in" at for Node in Self do line of avglvltree.pas.
Found no solutions on google.

Next: I have found some Lazarus tar file v0.9.30, extracted it make clean all.
Failed. Again some kind of error at some line in some file.

Next: I have found this page http://sourceforge.net/projects/lazarus/files/?source=navbar
Downloaded fpc, fpc source and lazarus 1.0.4 packages by going into "Lazarus Linux x86_64 RPM" link.
Turned out RPM belongs to another linux distrbution so installpkg doesnt work. Google told me i could use another package manager which was already in slackware, so i did, but then it started spitting out all the dependency missing stuff and i was way too tired to search for explanations as to what it was and where can i get it from. Each package resulted in even more errors.

Could somebody please tell me, step by step, how can i install lazarus and compile my dll?

I am sure i am doing something wrong (im really new to linux systems), but i have no idea what and none of the guides out there seem to tell me.


The solution appeared to be very simple.

The .rpm files are taken from SourceForge .

Instead of using rpm -Uvh <rpm file>, need to use rpm2tgz <rpm file> command. Doing this for all 3 packages will convert .rpm to .tgz.

Next just use installpkg <tgz file> command to install them all, one by one. It takes quite a while.

Executing fpc -i command will show supported target systems (along with other information) where 'Linux for x86-64' was what was needed.

I had xfce 4 desktop manager installed with my Slackware 13.1 x64 so i ran it using startxfce4. Lazarus appeared at the 'Development' menu.

After opening Lazarus and the library project, need to go to Project > Project options... > Compiler options > Code generation. In the Target platform section need to change Target OS to Linux and Target CPU family to x86_64. Additionaly in Compiler Options > Other, had to add -fPIC to custom options field.

Saved and built. The generated .so file is now usable under 64 bit SlackWare.

  • Lazarus is also found on Slackbuilds.org, and can be managed with sbopkg for better handling of upgrades. This method does, of course, do the job. – 0xDAFACADE Aug 14 '14 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.