64

I need "right to left" text direction to write in Persian.

86

Enable Complex Text Layout (CTL) support using (sources: 1, 2, 3):

    Tools → Options → Language Settings → Languages

It may be necessary to restart LibreOffice after enabling CTL.

Then:

Ctrl+Shift+D or Ctrl+Right Shift - switch to right-to-left text entry

Ctrl+Shift+A or Ctrl+Left Shift - switch to left-to-right text entry.

If the shortcuts don't work using Left Ctrl, try Right Ctrl.

  • 3
    Is there a toolbar icon for this? So I won't need to remember the shortcut. – AlikElzin-kilaka Nov 8 '14 at 15:02
  • @AlikElzin-kilaka: If you go to the menu Tools -> Customize, and then click on the tab "Toolbars", and then select the toolbar "Formatting", you'll see the buttons "Left-to-right" and "Right-to-left" there, although I can't get them to appear. – Flimm May 30 '15 at 14:46
  • What about any text box? For instance, Yahoo Mail Text Box? How can I change text direction there? – Royi Aug 30 '17 at 11:04
9

Add Direction Buttons like MS-WORD

As you remember in MS WORD there were to buttons in standard menu which acted as shortcut.

Go to VIEW>TOOLBARS>CUSTOMIZE

Select the tab "TOOLBARS"

Select "STANDARD"

Press the button "ADD"

Select Category " Format"

From the right pane select "RIGHT TO LEFT" & "LEFT TO RIGHT"

  • This question is about LibreOffice, not MS Word. – user187676 Dec 19 '17 at 6:58
  • I followed the this exact same procedure in LibreOffice Impress and it worked! – user3405291 Dec 24 '17 at 12:55
7

Does this solution work?

  • Ctrl+Shift+D or Ctrl+Right Shift Key - switch to right-to-left text entry
  • Ctrl+Shift+A or Ctrl+Left Shift Key - switch to left-to-right text entry

from https://help.libreoffice.org/Common/Languages_Using_Complex_Text_Layout

3

In Libreoffice 3, in the menu of tools > Options > language settings > languages

In Enhanced language support section, you should check "Enabled for Complex text layout (CTL)" to enable the key combination for text writing directions. Without this option, your Ctrl+Shift keys won't take effect. When enabled, then you can use

  • Ctrl+Shift+D or Ctrl+Right Shift Key - switch to right-to-left text entry
  • Ctrl+Shift+A or Ctrl+Left Shift Key - switch to left-to-right text entry
0

Tools >> Options >> Language Settings >> Languages >> Default Languages for Documents >> Complex text layout >> Select your language (Persian).
Now you could use:

  • Ctrl+Shift+D or Ctrl+Right Shift Key - switch to right-to-left text entry
  • Ctrl+Shift+A or Ctrl+Left Shift Key - switch to left-to-right text entry

protected by Community Feb 15 '15 at 14:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.