38

I'm really appreciating conemu as an alternative windows shell, but the alert bell sound is driving me crazy! (I wear earbuds and that sound goes right through me..)

Is there are an option to disable the bell alert noise (or switch for a screen flash or something)?

1
  • 1
    I'm suffering from the same same problem, UAC prompts and Comodo popups are deafening, too. Starting with Vista you can mitigate the problem by reducing the volume of just the system sounds. (and any other single application) – Daniel Rikowski May 29 '14 at 9:52
10

There is "Suppress bells" option.

ConEmu: Suppress bells

8
  • 17
    It's tab-complete in bash! (I'm a tabaholic) – danodonovan Jan 30 '13 at 17:15
  • 2
  • 1
    This is not really a good answer. It's certainly true that there's no option in ConEmu, but it's not a ConEmu issue, it happens in (some) terminals, particularly when you're ssh'ing into remote terminals where the bell is turned on globally. I added another answer... – paul May 28 '14 at 22:23
  • 6
    As of Feb 2017, there DOES now seem to be an option in ConEmu settings to "Suppress bells". But for me, it has no effect on the Windows 'Critical Stop' noises I'm hearing all the time (not in tab-complete, but, say, when backspacing on an empty line in WSL Bash) – Jonathan Hartley Feb 16 '17 at 3:08
  • 4
    This option does not seem to be suppressing any bells... – Metagrapher Jul 29 '17 at 17:46
26

It's caused by the terminal, not ConEmu. For example, it doesn't happen in a local terminal in msys (= Git Bash), cmd, or Cygwin (for me). It happens when you ssh into a remote machine (or VM). To fix in Bash you just need to run this command:

set bell-style none

To always turn off the bell in the future, place this command on a line in a file called .inputrc. I think it will also work in .bashrc. You can do this via your text editor of choice or on the command line with:

echo "set bell-style none" > .inputrc

Of course, you'll need to do this whenever you get to a new machine that does this. You can turn it off globally in /etc/inputrc. You can also set the bell style to 'visible' instead of 'none' to make the terminal flash.

There are other ways to turn off the bell in other shells and programs: http://www.tldp.org/HOWTO/Visual-Bell-8.html

9
  • How is this not a ConEmu problem? The terminal is running on a remote computer and is certainly not producing any sounds on the local computer by itself. – Tuure Laurinolli Nov 4 '15 at 15:45
  • ConEmu is just executing the bell command that it was given by the terminal. It's not a bug because the developer chose to make it work this way. I believe the developer has said he may add sound controls to ConEmu in the future, but this would be an additional feature github.com/ConEmu/old-issues/issues/988 – paul Nov 4 '15 at 19:46
  • Yes, and the question is about disabling the bell feature in ConEmu. Thus the answer is "it's currently not possible", and the workarounds are to a) change the application running in ConEmu to not caus bells or b) disable the Beep service. – Tuure Laurinolli Nov 5 '15 at 9:27
  • Correct. But I believe the question-asker just wanted their computer to stop beeping at them, so they really wanted to know the workarounds, hence my answer being a good one and Maximus's answer being not as good (despite that fact that he made ConEmu, which is awesome) :) – paul Nov 5 '15 at 19:14
  • 1
    The latter works, at least after restarting. Wasn't able to get the first option to work, probably due to caching. – nilskp Oct 31 '17 at 15:52
14

A simple solution is to go to the Volume Mixer and set the volume for "Console Window Host" to 0. This will prevent any console from making any sounds at all. But in practice the only sound it makes is that horrible bell and this will silence it.

In Windows 7+ this sound is played by the Bell driver. In Windows 10 at least, you can change the sound it makes by using the Sound control panel to alter the noise it makes for the Critical Stop event. I found Windows Ding was a better choice for ConEmu, no idea what other apps might play that sound.

2
  • 1
    Both of these ideas worked for me, while more popular answers (change 'default beep' sound, and Bash 'set bell-style none') did not. – Jonathan Hartley Feb 16 '17 at 2:57
  • I ultimately had to set "System Sounds" to zero, and that did it. – chris Mar 9 '20 at 22:00
9

The bell-style option is already in .inputrc, but commented out. Unfortunately uncommenting it doesn't resole the issue for me.

The only resolution that works in my case is setting no sound for Default beep. I know it's global but this is better than nothing...

enter image description here

3
  • 3
    For me, changing 'default beep' didn't affect ConEmu. I had to change 'critical stop' sounds instead. (I'm running WSL Bash in ConEmu) – Jonathan Hartley Feb 16 '17 at 2:58
  • 1
    That didn't work for me as setting it to None made the computer revert to use a built-in (even more annoying) beep sound. By setting it to an empty .wav file such as the one at this address made it work: forums.civfanatics.com/threads/silent-wav-file.500379 – laurent Apr 12 '17 at 8:25
  • 1
    Critical Stop worked for me too. – Artem Russakovskii Nov 29 '17 at 23:42
3

This is not a ConEmu specific solution, but you can disable the Windows system bell if you don't mind never being bothered by this at all. As one of the answers there suggests, you can find "Beep" under "Non-Plug and Play Drivers" in the Device Manager and disable it on the Driver tab under "Startup" (Note: you will need to "Show hidden devices" under the "View" menu to be able to see the "Non-Plug and Play Drivers" section).

device manager screenshot

0

None of the above worked for me so I created a short silent .wav file, put it in c:\Windows\Media and used that as the sound for Critical Stop

Here is the the download link: http://s000.tinyupload.com/index.php?file_id=96334642005554838230

2
  • Why not just set Critical Stop to None? Worked for me. – Artem Russakovskii Nov 29 '17 at 23:42
  • I don't remember now @Artem Russakovskii, but I assume I tried turning off Critical Stop. But if it works for you, then yes, that's a better option. – Daniel Nov 30 '17 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.