22

When I installed Windows 7 on my new SSD it seems I messed some parts up during the partition selection, and now I have my system partition with the boot sector on another harddrive, and the boot partition containing Windows on my SSD.

How can I move the boot sector from my hard drive to my SSD, so that the system and boot partition are both the SSD and I don't need the hard drive to boot anymore?

I'm a bit lost on how to do this, as I don't have any idea how I split them in the first place. When I had to repair the boot sector using BootRec.exe I could only put it back on the hard drive, I saw no option to create one somewhere else.

I also want to keep all content on my SSD, so reinstalling Windows is not an option.

Here's a screenshot of my current disk layout (in german, but most terms should be easily recognizable):

enter image description here

  • 1
    Did you try disconnecting the HDD before running bootrec? – Karan Jan 30 '13 at 18:08
  • My boot partition was silently installed to the D drive when I installed windows 10 from scratch on the C drive. Finding out that I cannot boot from the C drive alone was maddening. I can't believe Microsoft still does this kind of user-hostile behavior that I grew jaded to in Win95 and XP days (before I left the ecosystem for better pastures) – chrishiestand Jul 14 '20 at 0:22
11

I finally used Easy BCD, which is free for personal use. The bcdboot method didn't work for some reason for me, the command exited sucessfully and copied files, but I still couldn't boot from c:.

Easy BCD has a "Change boot drive" option under BCD Backup/Repair, which worked in my case.

  • 1
    Didn't work for me. Easy BCD told me C: is not a primary partition and refused to do anything (it is a primary partition). – Petr Peller Mar 23 '17 at 20:45
  • Saved me from a painful reinstall, this worked for me in Windows 10 and thank you! – chrishiestand Jul 14 '20 at 0:23
8

I believe the command you need is:

bcdboot c:\windows /s c:

It seems you describe the exact same issue that Scott Hanselman does in this blog post

  • 1
    This worked for me as well. In my case, as also pointed out in the comments of the blog posts, I had to mark the partition as active as well. – Wouter Nov 15 '15 at 18:28
  • Worked like a charm - you have to execute it as admin and you should keep in mind to use the correct drive letters if the drive you want to boot from is not on `c:\` – Marwie Sep 30 '16 at 14:58
  • (Windows 10) Thank you, this worked perfectly. I had an old installation on an unused but connected drive that audibly started failing and unplugging it would prevent my useful installation from booting. Running this command in a "run as administrator" cmd window solved the issue. Beautiful! – qubodup Sep 1 '17 at 11:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.