I thought I'd make my first SuperUser question relatively simple, though it's the kind of question that may not get many responses as I'm not directly involved with the issue.

A colleague does his development in Windows XP running in Parallels on his Mac. We've just migrated our VSS repository to SVN, and we've gone with TortoiseSVN as our client of choice with the Ankhsvn plugin for Visual Studio.

On his XP instance, after installing TortoiseSVN, browsing through folders using Explorer is extremely slow; about 15 - 30 seconds before the contents of the next folder displays. It's the slowest when opening My Computer. Once he reaches a folder that contains the working content of an SVN project, Explorer behaves quickly again as expected. It seems that TortoiseSVN may be spending a bunch of time searching subfolders for stuff so it can do its icon-overlay thing, but that's just a guess.

I've used TortoiseSVN for years on both XP and Vista on far less powerful machines without any issues with Explorer, so I'm attributing the slowness to it being run in a VM, though that may not be the actual issue.

So has anyone encountered similar performance issues, and/or know of a fix? Keep in mind that any requests to make changes to his configuration will need to be communicated and thus my response time might be slow.

Thanks everyone!


Settings dialog->Icon Overlays->Exclude paths: Set this to e.g.,


Then set the include paths to the path where the working copy is, e.g.

| improve this answer | |

I ran into very similar issue several times, and the "cache" tweak did notwork, and I was inspired by this post: https://groups.google.com/d/msg/tortoisesvn/IehAouUWrnA/srbHrGlCVR4J and tried using Wireshark myself to monitor what had happened during context menu launch.

As expected, several netbios name queries were found searching for a machine name but timed out. Then I remembered I had changed my computer name without restarting, so the tortoise svn is looking for that new name! So I did a reboot and things all went back to normal.

Hope this experience helps.

ADD: You can also try using Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645) to trace whatever happens when the lagging occurs. It always helps to identify abnormal registry/file/network access.

| improve this answer | |

I've seen similar symptoms (slow responses in Explorer) from tortoise, but in a different context (working copy was on a network share). In my situation, the solution was to go into Tortoise' settings and turn off Icon Overlay caching.

| improve this answer | |
  • Tried it; no change. Does Explorer need to get restarted or anything? – Cᴏʀʏ Oct 12 '09 at 18:41
  • It's worth a shot. Since it's a shell extension you would need to restart explorer at least, probably windows, to be sure everything is cleared out. – Joel Coehoorn Oct 12 '09 at 19:55

You can set the "Include paths"-setting in TortoiseSVN to let it know that it should only display overlay icons on the directories where you have your SVN project. The setting is found in Settings->Icon Overlays->Include paths.

| improve this answer | |
  • 1
    Tried it; no change. Does Explorer need to get restarted? – Cᴏʀʏ Oct 12 '09 at 18:42

When I ran into the same issue, I found this thread and tried the recommended solution by Stefan. In my case, I had to wait about 30 seconds until a right-click on any folder in any Explorer window showed the context menu.

After I adjusted the Exclude paths and Include paths in TortoiseSVN's Settings, the Explorer context menu went back to normal speed and showed up in no time.

In my case, I then found that TortoiseSVN was desperately trying to access some remote SVN projects folders on other computers in our company which I used to maintain from my computer via the Windows network, too. But when these computers are offline, it lasted the mentioned 30 seconds (or so) until Windows gave back a timeout.

Maybe there is another clue how to check whether network paths are available or not, but for the moment I prefer faster Explorer Context menu access.

Hope this helps others to locate their timeout issues, too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.