Since recently magnet links (from both Chrome and IE) don't launch in uTorrent as expected.
It used to work, and I have no clue what broke it.

When I click a magnet link in the browser, nothing just happens.

I uninstalled uTorrent (and removed all leftovers from Program Files and registry) then reinstalled new version (also tried beta version) and it didn't solve the problem.

I also checked the settings and uTorrent is set to default association for torrent files:
enter image description here

Here's the post I submitted on their forum should you feel to share some info.

  • Have you tried uninstalling and reinstalling uTorrent? doesn't sound like a browser issue if the problem spans multiple browsers.
    – MDMoore313
    Jan 31 '13 at 1:27
  • Nops. That didn't work. I even erased all the settings. Jan 31 '13 at 3:11
  • Facing same issue here, its a bugger Jan 31 '13 at 17:16
  • @kindrudekid Do you think it might be a bug in the latest uTorrent version? Jan 31 '13 at 21:08
  • Check the uTorrent forum for recent bug reports about the same thing. Also try running uTorrent as admin and restoring the magnet link association via Preferences.
    – Karan
    Feb 1 '13 at 4:22

The Latest Alpha Seems to fix the issue

Get the Alpha from here

  • Didn't solve the problem. Feb 6 '13 at 1:54
  • it did for me! exit utorrent and den start the installation, Feb 8 '13 at 16:14
  • I even uninstalled it, deleted all its leftovers in Program Files and in registry, and re-installed the new version and magnet links still do nothing! Mar 2 '13 at 22:37

The reason can be that you have the browsers blocking pop ups from the site or pop ups on a whole. When installing a browser at the end of the installation process, it ask if you would like to import information from your default browser. If you have clicked yes then the settings that apply to IE will apply to Chrome. So check your settings. If you are not sure what to look for simple uninstall one and install it again. Do not import any settings from previous browsers.

For best results I would use YOUR-Uninstaller in supermode. This will remove all unwanted files from the browser that may still linger on your computer and may contain the settings information.

  • 1) So why did it work up to this moment? 2) It's not the popups. My browser always shows an icon when a popup is blocked and it's not there. 3) As MDMoore313 said above, I'm pretty sure it isn't a browser issue at all. Jan 31 '13 at 14:29

Perhaps it's your ISP/company blocking magnet links? Try webproxy which supports ssl and magnet links. There are not many webproxies with that combination but I found https://thorify.com when my company started blocking nearly everything ;) Couldn't even download legal linux distros anymore with torrent.

I asked my IT-person and she said company router firewall rules torpedoes magnet links & shady URLs automagically, when I asked her about using webproxy to download distros & other legal torrents she said If firewall doesn't care I don't either :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.