4

I'm trying to use a Gigaware USB -> Serial adapter that worked fine on Windows XP on Windows 8. It's not working and I get

This device cannot start. (Code 10)

A device which does not exist was specified.

in device manager. It says the drivers are up to date. What should I do?

2

If this is your adapter - then it is based on Prolific PL2303 chipset and your best bet would be to use the drivers from the chipset manufacturer. But if your adapter contains an old revision of the chip - it is just not compatible with Windows 8:

Windows 8 is NOT supported in PL-2303HXA and PL-2303X EOL chip versions.

  • That is a specific version (direct download URL). Can you also provide a link that enables always getting the latest version? Does the first link do that? If so, can you make it more clear? – Peter Mortensen Apr 14 '18 at 23:00
9

This tool WILL work if you are receiving the (Code 10) error. Despite all the comments about it not working on Windows 8/8.1, there is a simple way to make it work: Fake PL2303 – how to install on Windows 8.1

Just installed the driver and now connection via COM is possible:

  • 1
    welcome on superuser. Your answer is borderline to be a link only answer, which isn't preferred as links can always break. Please edit it to include more information – Máté Juhász Nov 17 '15 at 10:42
  • 2
    +1 This worked for me on Windows 10 – Justin Jul 29 '16 at 22:02
  • 1
    Installing v3.3.2.105 drivers also worked for me on Windows 10. Great information! – ausadmin Mar 25 '17 at 23:42
  • Why would you trust something downloaded from domain wp.brodzinski.net? – Peter Mortensen Apr 14 '18 at 23:08
  • The link suggests it is due fake chips, but it is more likely that it is due to the chip manufacturer's decision to not support the older versions of the PL2303 on newer versions of Windows (not due to fake chips). Their driver page says "Windows 8/8.1/10 are NOT supported for PL-2303HXA and PL-2303X ... recommends to use PL-2303HXD (HX Rev D) or PL2303TA". – Peter Mortensen Apr 15 '18 at 10:28
4

You need to downgrade the driver to the 2008 3.3.2.102 version and choose it specifically as per this page:

USB to Serial (Prolific 2303) Device Cannot Start (Code 10) in Windows 8/8.1/10

Or the duplicate answer on Super User page Gigaware USB to serial adapter not working on Windows 8.

I found that this was needed when using the ADAfruit USB-to-TTL adapter cables.

The only issue is that every time you remove the device you will have to go through the same painful exercise as Windows doesn't retain the driver association details.

1

Download this driver from the Windows Update Catalog. Then manually add the driver using Device Manager.

  • +1 for this answer! I had the same problem with my son's Cub Scout Pack's computer. I downloaded this driver and the converter is working now. – Jim Clark Feb 1 '14 at 11:55
  • I got "The website has encountered a problem [Error number: 8DDD0010]" when I tried it. – Peter Mortensen Apr 15 '18 at 12:07
0

I also download the driver listed (AMD64_X86-en-20357822_453c563f64689a47c9be3972b95db24900db3798.cab)above from Microsoft and manually added it. You must remove the Svk2pl.inf from the .cab, disable the device, select the .inf file. After you are done the will show up as Gigaware USB to Serial Cable (COMx) x=port. If you move the connection to another USB port you have to make the same change or you will still have the problem. The device works great now. I used the PL203CheckChipVersion.exe to verify my chip version, I am using PL-2303 XA / HXA chip. This tool will not work if you are receiving the (Code 10) error.

0

The adapter you are referring to is not compatible with Windows 8, and even updating the drivers will not make it work either since it most likely has the old version of the Prolific chipset. A solution would be using an FTDI based USB-to-serial converter which has better drivers and is compatible with Windows 8.

0

I also just had this problem, and I downloaded the "Windows Update Catalog" after uninstalling and reinstalling driver. I went to Device Manager and updated the driver with the file I downloaded.

It works great now.

protected by Community Jul 28 '15 at 11:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.