I am on Windows 7. I have some files on my computer leftover from an old version of Photoshop. (I think... I don't remember exactly where they came from, but they seem to be Adobe files.) There are 124 of them in a folder, which I have named "KILL." (I don't remember what the original name of this folder is, it's been on my comptuer a long time.)

These files seem to be absolutely undeletable, as far as I can tell. I can move them around and change the name of the folder, but deleting them is out of the question. I also can't move them onto a different hard drive or flash drive, I've tried that.

So, let me list the things I've tried first:

  1. A whole bunch of different "unlocking programs." Including: IObit Unlocker, Lock Hunter, FileAssassin, and Project Kill box. What I use LockHunter I am told: "No processes locking this file or folder have been found." All of the other programs I've tried give me similar messages, telling me that nothing is locking the files. Yet when I try to delete the files using LockHunter, I am simply told "Cannot delete x." No reason is given.

  2. Tried using cmd.exe. Even when I run a command window under administrator, it won't even let me access the KILL folder, much less delete anything. I also tried killing explorer.exe from the task manager, and then using the cmd window. Still can't even access that folder.

  3. Tried using safe mode in combination with these other options, doesn't change a thing.

  4. Tried changing permissions of the files using the security tab under properties. It simply says "not inherited." It will not allow me to change a thing.

  5. I am definitely the administrator of this computer.

  6. Tried Disk Cleanup and Defrag. I suspected that some files must be damaged or something, but Disk Cleanup wasn't able to find any errors. Defrag didn't help.

So, let me just say that I am not a computer expert. But based on all the things I've tried, I suspect that this might be some hardware problem? It seems strange that these files don't seem to be used by any processes, and yet are absolutely undeletable no matter what I do. Is there anything else I can try? Has anyone had any similar experience, and have any idea why this might have happened?

EDIT: Interesting recent development. As I have toyed with moving the folder around, I moved it to the Program Files folder. Now that it's there, it suddenly CANNOT be moved nor renamed. It is stuck there, apparently permanently, as a folder called "KILL." How irritating.

  • 4
    Have you booted with a Linux Live CD and seen what there is to see when you examine the filesystem from Linux? – Jonathan Garber Jan 31 '13 at 21:49
  • 2
    Can you be so kind as to download and try removing this directory with the free version of my Hamilton C shell? Try opening an elevated window using sudo, then chown -rR KILL followed by rm -x KILL. You may need to edit the ACL, e.g., cacls KILL /e /r everyone. My chown and rm support long UNICODE names and I intend for them to let you remove anything, so I'm looking for any test cases I haven't covered. – Nicole Hamilton Feb 1 '13 at 0:38
  • I'm going to try the Linux Live CD thing, but I have no idea how it works. My question is below. – Brion Foulke Feb 1 '13 at 21:24
  • Related: superuser.com/q/28912/193661 – user193661 Sep 23 '15 at 4:57

Your next step should be to boot from a Linux Live CD and try to delete the files.

First download any Linux distribution (often called distro for short). You can look at this list on Wikipedia and there's quite a lot of them, so my personal recommendation is that you use SliTaz which is a very small download (about 35 MB) and still has all the functionality of Linux.

Next downlad the LinuxLive USB Creator and use it to create a Bootable USB from the Linux ISO file.

Update: USB Boot.

Check if your BIOS has enabled Boot From USB

1 Reboot your computer and plug in your USB with the boot disk formatted on its drive.

2 Press the key that sends you into the BIOS setup screen -- usually F2, F10, F12 or the ESC key, depending on which BIOS type your computer runs (the exact key depends based on what computer model you have).

3 Go to the "Startup Options" section of the BIOS. Use the arrow keys to navigate. Instructions are usually posted for paging and changing selections.

4 Set your USB drive to be the primary boot disk in the BIOS setup. Go to "Boot Order" or "Advanced Settings" depending on your BIOS menu, then go to the "Removable Devices" option and choose your USB drive from the list.

5 Save the settings and exit the BIOS. The computer will reboot

6 Then boot from the USB by pressing ESC or F10 at the boot screen, to get to the boot menu, and select Boot From USB.

Note: If your BIOS does not support USB boot you can try this trick

SliTaz will Boot automatically and ask for your language and keyboard settings, when you get to the desktop, click on Applications > System Tools > PCMan File Manager enter image description here then browse to the files you want to delete and press Delete.


  • To verify you are advocating using a Linux distribution to delete NTFS files? This solution feels wrong and I was under the impression that Write access for NTFS under Linus was still a bit unstable. Personally I'd be concerned for my NTFS integrity. – mdpc Feb 1 '13 at 3:23
  • I have done so in the past with no issues, so my answer is based on my experience, but if you have had trouble doing this I will edit or remove any misleading answers – user181734 Feb 1 '13 at 4:00
  • 2
    I didn't see the original comment, but up-to-date, modern Linux distros shipping recent ntfs-3g should be able to handle NTFS with 100% stability. It still doesn't respect permissions (in that everything on the drive is world readable and world writable), but they're discretionary so it's not like it's violating the filesystem design; far from it. Ntfs-3g handles write operations with perfect stability on NTFS volumes. I've been using it almost every day for 5 years and have never encountered a problem caused by ntfs-3g. – allquixotic Feb 1 '13 at 12:43
  • Thanks for the reply. I'm going to try the Linux Live CD. I've seen other people suggest this option but I was intimidated by it. Maybe you can help walk me through how this works because I have no idea. So I downloaded the "stable" version of Slitaz (whatever that means), "slitaz-4.0.iso." I also downloaded the Linux Live USB Creator. I tried running it. I'm confused by Step 1: "Choose a USB key." What does this mean, and what am I supposed to do? Is it something to do with a flash drive? – Brion Foulke Feb 1 '13 at 21:23
  • An update: I figured out that I was just supposed to put a flash drive in, and it seemed to create the Linux Live CD thing on my Flash Drive. As far as I can tell, it worked. The problem I'm currently having is that I don't know how to use it. I rebooted my computer, pressed F12 to load the boot screen, but among the options there are 4 similar to what you told me to select: "USB FDD, USB ZIP, USB CD Rom, USB HDD." I didn't know which of these was right, so I tried them all. Three of them just boot my computer in windows normally. The other, USB Zip, makes my computer hang. – Brion Foulke Feb 1 '13 at 23:10

Open a Command Prompt window and leave it open.Close all open programs.

Click Start, Run and enter TASKMGR.EXE Go to the Processes tab and End Process on Explorer.exe. Leave Task Manager open.

Go back to the Command Prompt window and change to the directory where the undeletable file is located in.

At the command prompt type DEL where is the file you wish to delete. Go back to Task Manager, click File, New Task and enter EXPLORER.EXE to restart the GUI shell. Close Task Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.