4

In windows 7, when you right click a file and press r it opens the file's properties window.

With my new windows 8 (en-GB) install, the keyboard accelerator has changed to o. This is inconvenient for me, as almost every file ever is going to have "Open" listed as the first thing in the context menu with, you guessed it, o as the accelerator. So now neither of these options can be selected with one key press.

Is there any way to change the properties accelerator back to r?

I've included some screenshots from 2 different computers (the first one installed only 3 days ago and not touched since). The only difference i can think is that on the very first screen in the Win 8 installer, I chose (actually, it might have been the only option) british english as the "display language" since I am in australia.

In the screenshots, the keyboard accelerators show as the underlined letters in the menu. Pressing the underlined letter will activate that menu choice - unless there are 2 with the same accelerator (in which case it only highlights them and a further key press alternates between them). To show the underlines, go to Control Panel -> Ease of Access -> Change how your keyboard works -> Underline keyboard shortcuts and access keys.

laptop desktop

  • I just tested this complaint. The default keyboard accelerator actually is r. If its not on your system, then a setting was changed, I have no idea what the setting is. – Ramhound Feb 2 '13 at 1:07
  • I've added some screenshots – Luke Feb 2 '13 at 2:56
  • Luke, I don't understand what your screenshots are supposed to show, sorry. The keyboard accelerator doesn't show up onscreen at any point. – Marcus Chan Feb 2 '13 at 3:16
  • 1
    They are the underlined letters in the screenshots. Up to XP (I think) they were always underlined, now they will only underline if you press alt or turn them on permanently. (Control Panel -> Ease of Access -> Change how your keyboard works -> Underline keyboard shortcuts and access keys). – Luke Feb 2 '13 at 3:21
  • ...whoa, you're right, that's really weird. I stand corrected. Edit: Might be clearer for others if you crop the screenshots to just a little larger than the context menus – Marcus Chan Feb 2 '13 at 3:43
3

Update: Microsoft keep making this harder to do with each successive update to Windows 10. You may need to go into an offline Command Prompt to replace that file (e.g. the Safe Mode Command Prompt – to get here, click Start, then hold Shift and click Restart. If you need more help finding it from there, then look online). It helps if you have put the edited system32.dll.mui somewhere easy to access.


It is possible to fix this... but not without being being prepared to go about it in an unusual manner and get your hands a little dirty with a hex editor.

You will need:

  • A hex editor;
  • Admin privileges and the ability to get elevated permissions to system folders.

Basically, the issue is that some idiot lovely person at Microsoft thought that no one using en-GB (which includes other variants - such as myself with New Zealand English) would care that they broke the accelerator keyboard shortcut. Again, I'm left wondering why software companies don't realise that a lot of the world actually want to use real English, not US-English. For that matter, they don't seem to believe in using keyboards either, what with the creative ways they use to hide accelerator underlines. Anyway, fixing involves only changing two characters. In a protected file hidden under System32, frequently accessed by the OS. :-)

Microsoft handle languages in Windows using "MUI" files (for Multilingual User Interface), basically files matched against whatever program or DLL they are for, which can be easily swapped out with a new language when needed, without requiring a change to the binary executables. The files are named with an additional ".mui" appended to the original file's name (example below). It's elegant in theory, but being Microsoft they made the language pack files non-human readable, because... reasons? Not like a human would ever want to be able to edit a language pack file, surely. :-/

Go to C:\Windows\System32\en-GB, and open up the file shell32.dll.mui in a hex editor. You will need a hex editor for two reasons: one, many text editors will alter the file in some way you are not expecting, and that will kill a binary file; and two, the text in the file appears as character+null, not just character. Look for P.r.&.o. (dots are nulls) and replace it with P.&.r.o. (basically, swap the positions of & and r – or, move the & one character earlier). Because we are not changing the length of the file at all, it doesn't break it.

Now comes the annoying bit: you will probably need to save that file somewhere other than it's original folder, as you need to be running elevated privileges to access the folder, and even then, Windows doesn't like these files being overwritten (I suspect it may be that explorer is trying to access the file as you attempt to write to it).

So, what worked for me was: save the file somewhere, give it a different name (I just added ".n" for New), save it back into that folder, rename the original to something different (I added ".o" for Original), and name your new file shell32.dll.mui in place of the original.

Et voilá, I now have the proper "Properties" shortcut back!

I'd log it with Microsoft as a bug, except that earlier today I removed the Windows Feedback app as part of my trying to get rid of annoying things in Windows... :-)

One last point: this may very well get broken again by updates from Microsoft. I would say to keep the edited file on hand, but it would probably be safer just to re-apply the edit, in case something else gets changed in that file. If anyone wants a copy (saving you the hex edit step), let me know and I will try to find somewhere to share it.

I have officially spent more time on this than I will ever save from it, so hopefully it is useful to someone else! :-)


Edit: final note, this was done on Windows 10, not 8, but I figure the same should probably apply to 8 as well (I don't have 8 to test it on).

  • This is awesome, I will try to find some time to test it and mark as the correct answer. – Luke Apr 17 '17 at 18:34
  • Good to hear. :-) Also, I was proven right with the comment that future updates may require it to re-applied – this happened with the Win 10 Creators Update (the file was overwritten with one that is a slightly different size, and it reverted the change, meaning I had to do it again). Not sure how often updates are going to affect this, but it is a system file, so Windows is going to think it's "wrong" whenever it does a check of system files. – BevanFindlay Apr 19 '17 at 4:24
  • Brief update: the Fall Creators update decides to reset a whole range of customisations (thank you Microsoft, I really wanted you to change all those things that I explicitly set). Sigh. Admittedly, this bug is one of the ones I would expect to change, however they make it harder to solve. In the end, I had to change the owner on the original file, add permissions to it, then do the rename (and ended up doing that using a command prompt). Each step of "breaking" the security of the file included the requisite unnecessary warnings. But it does still work. Just give me sudo, gah! – BevanFindlay Oct 28 '17 at 7:30
4

The shortcut / accelerator appears to be related to your Windows display language setting.

I managed to fix this by:

  1. Going to Control Panel -> Clock, Language and Region -> Language
  2. Clicking Add a language then selecting English and English (United States)
  3. Clicking Options next to the newly added language
  4. Clicking Download and install language pack and waiting for it to finish
  5. Clicking Make this the primary language and logging out

I still think it's a terribly silly idea to have the same keyboard shortcut/accelerator for properties and open (which are going to be present in the menu of almost every file) in any language.

  • We didn't dismiss it, per se (okay, whoever downvoted did, but I don't think ramhound did). To be honest, I'm betting it's a Windows bug. Edit: Accept your own answer, by the way! – Marcus Chan Feb 2 '13 at 3:51
  • It's all good, the discussion (and confirmation that the problem was fixable) led to the fix anyway. – Luke Feb 2 '13 at 3:54
  • @MarcusChan - This isn't a bug the default setting was changed. The entire problem was the wrong language pack was installed – Ramhound Feb 3 '13 at 18:36
  • 3
    @Ramhound I'm sorry, how exactly is UK English the "wrong language"? Never mind the fact that I couldn't choose any other language when first installing and it was the default setting; you find it logical to have the same shortcut key for the two most common menu items - thereby negating the entire point of the shortcut key? The original question was about changing the shortcut key, not about changing the language pack or simply denying the problem (as you are doing). This solution is a workaround, at best. – Luke Feb 3 '13 at 23:06
  • 1
    I agree with Luke, this is ridiculous. If it's an entirely different language then I would tend to agree, but making this change between en-US and en-GB is ridiculous, and kills years worth of muscle memory. Also, it's not just a language pack issue. Considering that this is the first time (with Win8) they have ever released an entirely separate en-GB version of Windows, they should have done a far better job and avoided silly yet extremely annoying changes like this. – Karan Feb 4 '13 at 0:56
1

In my clean Windows 8 install (virtual, but it shouldn't make difference), r works exactly as expected.
Edit: Hmm, that's weird. Mine has the underline in the normal place, as I'm sure the other SU users have it. Maybe it's your language setting, I'm not sure.

In any case, Alt+Enter is a much easier way of opening the properties menu, in my opinion (no mouse movement).

  • I can't even find what this feature actually is called. I found some documentation on how to create a keyboard accelerator within a program, likely something else entirely though based on what I can tell. – Ramhound Feb 2 '13 at 1:15
  • In my clean Windows 8 install (british english, maybe this makes a difference?), it doesn't. I haven't read about this change and as you have no doubt experienced, extensive googling only returns the 1000s of articles people have written about the new Win+x etc keyboard shorcuts that windows 8 has introduced. Thank you for the Alt+Enter tip though. – Luke Feb 2 '13 at 2:55
  • @Luke - You using a different keyboard more then likely has EVERYTHING to do with it. – Ramhound Feb 3 '13 at 18:37
  • I use many different keyboards, but they all use the standard (for my country and yours) 104 key US keyboard layout. I really don't see how that relates to the original question, the problem I was having or the workaround I've posted. – Luke Feb 3 '13 at 23:22
  • 1
    @Luke - Alt + Double click also brings up properties. I have exactly the same issue you have. I too am a Brit with UK English language settings. – Chris Driver Mar 5 '14 at 12:20

protected by Community Mar 14 at 20:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.