Is there any way of making dropbox's lan sync working on a virtual machine ?
Another "dropboxed" machine in the LAN is a standalone PC running *buntu 12.04 amd64, not a VM.

detailed info:

host OS: Windows 7 64 bit
guest (VM): *buntu 12.10 amd64

target LAN is: inet addr:192.168.0.x Mask:
while out of the box virtualbox's settings yield: inet addr: Mask: (NAT mode)

I've already tried to tamper with those settings and the most promising ones that I've managed to get are:
networking mode: "Bridged adapter", same LAN prefix, same MAC address as the host (with different MAC it wasn't possible to circumvent local network access denial), but neither Dropbox nor the Internet is working

Installing Dropbox on the host and mounting the folder to guest is last resort


I haven't used Dropbox on Linux, but have used it inside virtual machines. This should work as long as you set the VM network adapter to "Bridged" mode. Your virtual machine and and physical machine should then be on the same subnet, with similar IP addresses, i.e. both 192.168.0.x, but both with different MAC addresses. Then they should be able to find each other and do LAN syncing.

If you've changed the VM MAC address after installing the OS, it may be the case that you're experiencing the problem explained in this thread:


With the adapter set to bridged mode, and a unique MAC address for the VM, try running ifconfig in the VM. See if the ethernet interface exists, and if the VM has connectivity to the internet. If not, leave the unique MAC address as is and try the solution from that thread. It sounds like that's your problem, since you say the VM now has no internet access.

The aim is to get your VM onto the same subnet as the physical machine. Bridged mode is the adapter setting you need, since if using NAT mode, the virtual machine gets placed in a different subnet than the physical machine and the Dropbox software may not be able to recognize they're on the same physical network.

  • After several changes of MAC I don't have the problem you mentioned. Right now the VM is in the LAN (192.169.0.x), but gets recognised by local network as an unauthorised PC - I'll let know whether settings work after adding the VM to the LAN (It's not up to me). But thanks for directing me to the correct settings – vucalur Feb 3 '13 at 7:27
  • It works! As expected VM is now just another host in the lan. Thanks – vucalur Feb 17 '13 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.