15

When I open my video folder, the thumbnails aren't showing. Instead, the default VLC icon was being displayed. Other files and image thumbnails are being displayed properly, only the videos have problems.

The "always show icons, never thumbnails" option is unchecked.

What could be the problem?

I have also installed the K-lite codec pack, I tried clearing the thumbnail cache, but it's not working.

My problem is similar to this, but with videos: Windows 7: Image thumbnails fail to appear

3
  • 1
    Why don't you use Windows 7 Codecs in place of VLC, and it works with all thumbnails.
    – user181734
    Feb 3, 2013 at 0:55
  • 1
    @James I fixed this using Icaros which is also included in Windows 7 codecs,but is there a way to do this without using any sw? Anyway does the Icaros sw run in the background?Does it have any effect on the system?
    – ryux
    Feb 3, 2013 at 6:22
  • 1
    @JamesYoung I tried installing the Shark007 Windows 7 Codecs, but even though I unselected their "offer" of extra software, my system was infected with undesired software: Something called "Mobogenie", "Search Protect", and my home page and default search engine in Google Chrome changed to the Conduit search engine. All this before even finishing installing Shark007 itself! Thankfully I had created a restore point before the installation, and I strongly recommend anyone else who tries this to do so too.
    – waldyrious
    Mar 14, 2014 at 23:50

5 Answers 5

9

I had the same problem. Just found this link about Media Preview, installed it and worked perfectly. My thumbnails are back:

http://www.snapfiles.com/get/mediapreview.html

Media Preview enables Windows Explorer to display video thumbnails for just about any video format out there. If you are seeing blank or generic thumbnails for some of your video files, just install Media Preview and select the formats you want activate. The next time you open your video folder, it will display thumbnails for all your movies.

3
  • Works great, but doesn't add width and height properties for my mp4 files. May 21, 2014 at 12:22
  • Wow, this program is awesome! Thanks so much it works perfectly on Windows 7 64 bit even inside Xyplorer. However note that it does not select any file formats by default - you must configure it after install to choose the formats you want. Also, here's a direct link to the author's website: babelsoft.net/products.htm Jul 25, 2015 at 3:41
  • Notice, Total Commander may crash with this solution. Jun 18 at 14:38
6

I managed to fix this. The problem was that my registry entry was modified incorrectly by some software.

The HKEY_CLASSES_ROOT\.mp4\ShellEx entries were modified. I changed them to this:

[HKEY_CLASSES_ROOT\.mp4\ShellEx]


[HKEY_CLASSES_ROOT\.mp4\ShellEx\{BB2E617C-0920-11D1-9A0B-00C04FC2D6C1}]
@="{c5a40261-cd64-4ccf-84cb-c394da41d590}"


[HKEY_CLASSES_ROOT\.mp4\ShellEx\{e357fccd-a995-4576-b01f-234630154e96}]
@="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"

merged it and restarted my PC.

2
  • 1
    I got this exact situation. I wonder what application caused this (my guess VLC)? Specifically only mp4 registries are gone.
    – Cerlancism
    Sep 13, 2020 at 14:12
  • I had the exact same thing right after I uninstalled VLC so there is a chance VLC is doing this. Either VLC or MPC-HC which I had installed as a replacement for VLC... Oct 18, 2021 at 19:14
3

I fixed this changing the settings of K-lite codec pack:

  1. From start menu choose All Programs.
  2. Click K-lite Codec Pack folder.
  3. Click Codec Tweak Tools folder.
  4. Open All options.
  5. Click Thumbnail Settings.
  6. Select the file types for which you would like to display thumbnails or click Select Windows default.
  7. Click Apply & Close.
  8. Restart the computer for this changes to take effect.
1
  • 1
    no icons whatsoever for my VLC until aplying this fix
    – user162573
    Mar 31, 2014 at 15:25
1

I had the same problem until I tried to change the settings of K-lite codec pack and succeeded at getting most of video formats to display the thumbnail preview. I hope it works with you too.

  1. Open the K-lite codec pack's options from view tab.
  2. From the left choose "Formats".
  3. Click on "Modify".
  4. Under "Association" uncheck "with icon". Apply and it should take effect immediately.
1
  • That did it for me. I had previously downloaded the K-Lite Coded Pack a long time ago but uninstalled it. I reinstalled the Full K-Lite Codec Pack, ran the Codec Tweak Tool, under Miscellaneous => Thumbnails => Select none => Apply & Close. Thumbnail previews instantly showed up!
    – yellavon
    Feb 11, 2014 at 5:50
0
  • Double check in Default Programs to make sure that your selected Media Player is set as the default program for video files, and all of it's associations set to it as well. One or more of the associations may not be set.

  • Or use the System File Checker to fix any coruppted files that are causing this issue.

    1. To do so, open an elevated command prompt. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.enter image description here

    If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

    2. Type the following command, sfc /scannow and then press ENTER

    3. Once the scan completes, restart the computer and check the difference.

The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

  • You can also use the Windows 7 Codecs in place of VLC, and it works with all thumbnails.

On another note, apparently if you're low on disk space then Windows will not generate thumbnails for you.

  • Regain disk space on C drive with some uncommon methods or use Ccleaner and you should start seeing thumbnails. I think the minimum space you need on your Windows drive is 500 MB.

  • Using a patched explorer.exe can also cause this.

  • You can also try to fix this by reseting the Windows file extensions as explained in this post.
1
  • Thanks for the answer but I had already tried this and they didn't work.
    – ryux
    Feb 3, 2013 at 15:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.