My headphone jack doesn't work under Windows 7 64 bit.

I tried the following things:

  • 3 different headphones speakers
  • 2 different versions of the Realtek driver (2.7 / 2.6)
  • Standard Windows 7 drivers

I can't see anything apart from "Speakers" in the playback devices (I have enabled Show hidden / deactivated devices). Under Ubuntu there is no problem whatsoever!

When I used the Realtek configurator I wanted to disable the auto-detection of plugged in speakers, but the option (the little folder icon) wasn't there, in neither version.

I use HDMI to connect my screen from time to time. The audio jack from the screen does work (sometimes!). But I guess that's unrelated, because even when I boot Windows without the screen, it still doesn't work.

  • Is the audio device detected in Windows? Some older version of the Realtek hardware are not supported in Vista and newer.
    – Keltari
    Feb 3, 2013 at 0:33

8 Answers 8


Try completely uninstalling the realtek drivers and then reboot and see if Windows propitery audio drivers detect.

Hopefully the audio device has been correctly detected by Windows, to check it go to "Device Manager"

  • As mentioned, I have tried the standard Windows driver already.
    – Otze
    Feb 3, 2013 at 17:05
  • I don't have RealTek but going to Device Manager and uninstalling the sound driver (Conexant) and restarting worked for me. Thanks. Feb 28, 2016 at 23:41
  • @AndrewCheong Glad it worked :) Mar 3, 2016 at 8:30
  • I did this, and it still didn't work at first. But after I did a start menu search for Sound, opened that, and then clicked Configure, and went through that wizard, the headphone jack did work.
    – jaycer
    Oct 11, 2016 at 14:14

I had the same problem in my Lenovo Thinkpad W540. Things were working fine and suddenly whenever I plugged in my headphones, Windows was not changing plackback device to headphone. This is what I did to fix the problem,

  1. Reinstalled the chipset drivers.
  2. Uninstalled the Audio Drivers and reinstalled it again.
  3. Updated my BIOS.
  4. Restarted my machine.

Now it working fine. When I plugin the headphones, windows is automatically changing the playback


I had a similar issue (Lenovo Thinkpad W540 using a docking station) and resolved it in the following way (note that the problem was with Realtek HD audio manager):

  1. Open Control Panel, if viewing by categories, click "Hardware and Sound"
  2. Click "Realtek HD Audio Manager"
  3. Click "Display advanced settings" in the upper right corner of the Manager window
  4. Select "Classic Mode" and click OK

This worked immediately for me, no restart required.


If the problem still persists after re-installing the drivers, you can use system file checker:

  1. Click the Start button.
  2. Type cmd in the search box.
  3. Right click on the cmd.exe file and select Run as Administrator.
  4. In the CMD window, type sfc /scannow.

This will scan for corrupted files on your system and try to fix them. If the issue you are facing was caused due to not performing shut-down properly and system files getting corrupted it will get resolved.


I had similar issue with my USB Headset connected to my docking station (Windows 7 and 10, Lenovo W540). Once in a while, the headset/microphone was not used, even though I was seeing them as being available and set as defaults, the PC would use to the built in speaker/mike instead. The solution was to reboot, but that is time consuming.

I found today that if I plug the headset in another USB port, on the laptop or on the docking station, it then starts working, no need to reboot!

Hopefully this will keep working for me, and maybe it helps someone else too, wasted lots of time rebooting to fix this problem.


If Windows is not recognizing your headphones go to your System BIOS. On startup, mine was F10 on keyboard.

Then I searched and found INTEGRATED AUDIO and it was disabled. Enable it and then SAVE CHANGES AND EXIT.

Do not touch anything else if you don't know what you're doing. You have few tabs in BIOS and it's different on other motherboards.

Mine is HP something.

Hope this helps you.


Okay so I'm guessing the problem is different for different devices. Here's what worked for me without any restart:

  1. Go to Control Panel (Windows + X)
  2. Under "Hardware and sound", click on "Manage audio devices"
  3. Under "Playback", right click on "Speakers: RealTek" if your headphones are not detected.
  4. Click on properties.
  5. Under Levels, you will see your microphone volume is on zero. Crank it up!
  6. Done!

Right click on the volume icon and select “Playback devices”. Now, right click on empty space and select, “Show disconnected devices” and “Show disabled devices”. Select “headphone” and click on “Properties” and make sure that the headphone is enabled & set as default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.